Issue 91727 - OpenOffice fails to start from a NFS volume
Summary: OpenOffice fails to start from a NFS volume
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0 Beta 2
Hardware: Mac Mac OS X, all
: P3 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2008-07-16 17:25 UTC by paulbloch
Modified: 2013-01-29 21:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description paulbloch 2008-07-16 17:25:01 UTC
We store our 3rd party applications on our NFS fileserver which gets mounted on /Network/Applications 
on the client.  When I double-click the application I get this message:

          The application cannot be started.
          The user interface language cannot be determined.

I tried this in my home directory (which is also NFS mounted with the same result.  It does start from the 
downloaded .dmg or if I copy it to a local hard disk.

Other applications (Microsoft Office or NeoOffice, for example) start fine from our NFS server.
Comment 1 michael.ruess 2008-07-16 18:53:22 UTC
Framework issue.
Comment 2 paulbloch 2009-10-28 19:45:35 UTC
I just tried it again with 3.1.1 (310m19(Build:9420)].  It still fails to launch.  The Console 
show this message:

10/28/09 11:38:06 AM[278] ([0x0-0x354354].org.openoffice.script[87590]) Exited 
with exit code: 77 

I am running on OSX 10.5.8 Leopard.  I'll be able to test it on SnowLeopard soon.
Comment 3 csdib 2010-02-14 07:57:46 UTC
having the same issue here using OpenOffice 3.2 on snow leopard 10.6.2.
Comment 4 danny1810 2010-02-14 08:30:34 UTC
we have a large, and growing, mac desktops, and we use NFS for most of
ower applications, and this is the only one that is failing, for a very
long time
Comment 5 irush 2010-03-25 12:31:00 UTC
*** Issue 91727 has been confirmed by votes. ***
Comment 6 irush 2010-03-25 12:52:29 UTC
The problem seems to be with the way mac os x handles the file extended
attribute, which over nfs are saved in the ._* files. ooo's registry seems to
read anything under the registry directory including those files which aren't
formatted properly and it fails...

A quick workaround is something like:
find -name '._*' -delete

Comment 7 icurtain 2010-07-05 11:02:13 UTC
I've just experienced this issue (exit code 77), when running directly from my Mac HD.  I was able to fix by 
deleting my user preferences under home/Library/Application Support/Open Office/