Issue 91779 - Incorrect math formula sizing upon loading
Summary: Incorrect math formula sizing upon loading
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: DEV300m24
Hardware: Unknown All
: P3 Trivial with 10 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
: 125642 (view as issue list)
Depends on:
Reported: 2008-07-17 22:38 UTC by gvarek
Modified: 2017-05-20 10:45 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Sample document to reproduce the problem (2.93 KB, application/vnd.oasis.opendocument.text)
2008-07-17 22:41 UTC, gvarek
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description gvarek 2008-07-17 22:38:55 UTC
For an automatically-generated file in Open Document Format (ODF), the math
formulas are incorrectly sized upon loading.

In the embedded content.xml file, a MathML formula is inserted in a draw:frame
object, like this, without the svg:width and svg:height attributes:
    [... MathML content here ...]

With version 2.3.0 (at least with Linux), this worked fine: Writer would
automatically resize all formulas upon loading.

This no longer works for subsequent versions, the last tested being DEV300 m24.
All the equations are sized to 0.201cm x 0.467cm, regardless of their content.

To be able to reproduce the problem, you can find a sample document (and
screenshots) here:
Comment 1 gvarek 2008-07-17 22:41:56 UTC
Created attachment 55195 [details]
Sample document to reproduce the problem
Comment 2 thomas.lange 2008-07-18 07:14:08 UTC
Comment 3 xquery 2008-09-24 16:25:47 UTC
it`s not related only to Math but also affect images - i hope this *can* be 
fixed in OO 3.0
Comment 4 thomas.lange 2008-09-25 00:24:08 UTC
TL->MAV: since this one is not Math specific and the problem might be at loading
already, can you please have a look? Thanks!
Comment 5 xquery 2008-09-25 10:01:23 UTC
look like in previous version on loading every foreign object was 
"recalculated". But then in version 3.0 performance was improved by discarding 
this operation, for now i guess that this can be improved by checking if object 
have not size attributes then "recalculate" this object so 99.9 cases when such 
dimensions present (native document) - performance will have not negative 
impact, and in few cases when somebody perform loading "self-generated" document 
this will allow to calculate dimensions (and preview image maybe) for foreign 

For now this error block possibility for using OO 3.0 as authoring tool for 
editing scientific articles in such STM publishing companies like Wiley. In turn 
it don`t allow rapidly grow popularity of ODF not only as ISO (sorry) standard, 
but also like widely accepted & *used* standard. I guess STM authors worth 
possibility to edit their articles in OpenOffice. 

Solving it in OO 3.1 instead 3.0 can be too late for some patients.
STM - Science, Technology and *Medicine*
Comment 6 basex 2008-11-25 16:34:04 UTC
is it possible to have this issue fixed in OOo 3.0.1? this is a big trouble for
everyone that is working with importation of MathML using XSL.
Comment 7 Martin Hollmichel 2008-12-10 11:17:23 UTC
move target to 3.2.
Comment 8 gvarek 2008-12-16 12:57:50 UTC
It is a pity that the target has been moved from 3.1 to 3.2. This problem was
not in version 2.3.0, so working code exists. It appeared in version 2.3.1 or
2.4, and so it will have been around in several consecutive versions until it is

But I understand not all problems can be corrected at once and some problems
have a higher priority than this one. 

Note that, without this problem, OOo could become a serious competitor to LaTeX
when it comes to scientific documents.
Comment 9 basex 2008-12-16 13:10:28 UTC
I'm working on the importation of scientific documents to ODF using the
Openoffice API and XSLT, and I can't find any automatic way of setting the size
of the equations. Is there any workaround for this problem? 
Comment 10 gvarek 2008-12-16 13:19:30 UTC
In this thread:
there is a macro posted by ms777. I haven't tried it (yet), but maybe it can be
used as a workaround.
Comment 11 mikhail.voytenko 2009-08-31 13:27:54 UTC
Changing the target to OOo3.x because there are not enough resources.
Comment 12 Regina Henschel 2014-09-19 15:32:02 UTC
Hi, are you still interested to fix this issue? If not, please set it back to default owner.
Comment 13 Alain Baudhuin 2014-09-20 15:07:06 UTC
*** Issue 125642 has been marked as a duplicate of this issue. ***
Comment 14 Alain Baudhuin 2014-09-20 15:13:07 UTC
Is there any chance this gets fixed in a next release? Issue 125642 was a duplicate, and it appears that several other issues we have encountered sharing scientific documents between Mac & Windows users come down to this root cause.
Comment 15 Marcus 2017-05-20 10:45:31 UTC
Reset the assignee to the default "".