Issue 92010 - insert sheet from file make Calc to crash
Summary: insert sheet from file make Calc to crash
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: DEV300m26
Hardware: All All
: P2 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
Keywords: oooqa, regression
: 92064 92251 (view as issue list)
Depends on:
Blocks: 88888
  Show dependency tree
Reported: 2008-07-22 20:44 UTC by delorea
Modified: 2013-08-07 15:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

bug report for crash (18.25 KB, text/plain)
2008-07-22 20:48 UTC, delorea
no flags Details
OOo crashes when inserting this CSV file (93 bytes, text/plain)
2008-07-23 13:54 UTC, Andrea Pescetti
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description delorea 2008-07-22 20:44:48 UTC
Trying to insert a sheet from a file, OOo calc crashes.
The filename is test
If the same file is named test.txt it works well.
I will attach the bug report
Comment 1 delorea 2008-07-22 20:48:09 UTC
Created attachment 55308 [details]
bug report for crash
Comment 2 delorea 2008-07-23 09:20:23 UTC
After analyzing the behaviour more in detail I found that:

1. The crash appens even if I select an incorrect file type
2. OOo 2.4 doesn't suffer this problem

I think it's a blocker bug because the default for the selection tab is "All
File" and the insert button is enabled when I select a file (so simply pressing
the Enter key I have a crash).

I don't append the blocker keyword but i think I should.
Please let me know
Comment 3 Andrea Pescetti 2008-07-23 13:52:23 UTC
I'm shortly attaching a small CSV file to make it easier to reproduce the bug.
1) Open Calc
2) Insert - Sheet from file
3) Select the attached file (which is a CSV file but lacks the canonical .csv
   extension in the file name), leave file type as "All Files"

OOo 2.4.1 correctly imports this as a CSV file, while current devel versions of
OOo3 crash.
Comment 4 Andrea Pescetti 2008-07-23 13:54:30 UTC
Created attachment 55327 [details]
OOo crashes when inserting this CSV file
Comment 5 oc 2008-07-23 14:22:02 UTC
Hi Daniel, one4you
Comment 6 daniel.rentz 2008-07-23 15:14:25 UTC
started. OOXML filter detection is not prepared enough for non-OOXML files...
Comment 7 daniel.rentz 2008-07-23 21:35:44 UTC
fixed in DEV300/dr65 (OOo 3.0)
Comment 8 daniel.rentz 2008-07-24 08:43:26 UTC
*** Issue 92064 has been marked as a duplicate of this issue. ***
Comment 9 daniel.rentz 2008-07-24 08:50:52 UTC
Note: Both functions "Insert sheet from file" and "Insert link to external data"
(see issue 92064) were broken and have been fixed.
Comment 10 amy2008 2008-07-24 10:05:40 UTC
to dr,
in Issue 92064, I try to import entire or part of a link. Oddly, Some links 
files can be imported successfuly but some can't. 
can you tell me what makes OOo carshed? It puzzles me.
Comment 11 daniel.rentz 2008-07-24 11:13:39 UTC
The crash happened in the file type detection for OOXML files (Microsoft Excel
2007 XML). Type detection is used to find the correct import filter for a file.
The OOXML detection was not prepared for invalid (non-OOXML) files at one single
place in the code. If there was no crash, some other import filter has been
found before the OOXML filter was tried. In this example, the text/CSV import
filter is tried after the OOXML filter thus the crash happens in the OOXML filter.

The fix will be available in one of the next milestones.
Comment 12 daniel.rentz 2008-07-28 17:29:07 UTC
back to QA
Comment 13 oc 2008-07-29 08:35:06 UTC
verified in internal build cws_dr65
Comment 14 Andrea Pescetti 2008-07-29 17:22:56 UTC
*** Issue 92251 has been marked as a duplicate of this issue. ***
Comment 15 thackert 2008-08-05 17:18:20 UTC
I can confirm, that OOo Calc crashes, when I rename the attached file to *.csv I
try to insert in in Calc ... :( This happens with DEV300m28 under Debian SID
AMD64. So I will reopen the issue, sorry ... :(
Comment 16 uwe.luebbers 2008-08-05 17:35:46 UTC
fix was integrated in OOO300m1, m28 is too old.
Set it to "fixed" again, sorry too.
Comment 17 oc 2008-09-19 10:51:17 UTC
reset to verified
Comment 18 oc 2008-09-19 10:51:45 UTC
closed because fix available in build OOO300_m6