Issue 92302 - To undo a frame copied into a table may lead to crash
Summary: To undo a frame copied into a table may lead to crash
Status: CLOSED DUPLICATE of issue 77784
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 1.0.0
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-31 03:43 UTC by chenjunjun
Modified: 2008-10-16 16:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description chenjunjun 2008-07-31 03:43:29 UTC
1. Create a table in a writer document
2. Create a frame out of the table data
3. Copy the frame into the clipboard
4. Paste the frmae as RTF text into a cell of the table
5. Forth click the undo actions
=> it crashes OO.
Comment 1 michael.ruess 2008-07-31 07:32:27 UTC
Tracked as issue 77784, should be fixed since DEV300m24 build. Which one do you
work with?

*** This issue has been marked as a duplicate of 77784 ***
Comment 2 michael.ruess 2008-07-31 07:33:05 UTC
Closing duplicate.
Comment 3 chenjunjun 2008-07-31 08:40:07 UTC
Does the issue 77784 corect already?Someone said it is due to undo,other said 
it is due to paste as RTF text.But I see on OOo3.0 Beta it is still crashed 
anyway.Maybe both the reasons is,not is paste as RTF only.
Comment 4 michael.ruess 2008-07-31 09:30:06 UTC
Yes, the fix was integrated in post-30beta build dev300m24. Please download
300m28 (or m27, don't now what currently is placed on the servers) and file your
issue based on that build.
Comment 5 chenjunjun 2008-10-10 08:06:40 UTC
On 300m5,it said:
OSL_ENSURE(false, "SdrPageView::DrawLayer: Creating temporary SdrPageWindow 
(ObjectContact), this should never be needed (!)");
crashed!
Comment 6 michael.ruess 2008-10-16 16:17:42 UTC
Ah, an even better information. This one is handled in issue 92711, fixed in OO
3.1 branch.