Issue 92356 - crash when hit 'F5' in the undocked Navigator
Summary: crash when hit 'F5' in the undocked Navigator
Status: CLOSED FIXED
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOo 2.4.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: stefan.baltzer
QA Contact: issues@ui
URL:
Keywords: crash, oooqa
Depends on:
Blocks: 84291
  Show dependency tree
 
Reported: 2008-08-01 02:58 UTC by wuyan.ooorg
Modified: 2017-05-20 09:26 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch of sfx2/source/appl/childwin.cxx (305 bytes, text/plain)
2009-06-03 10:45 UTC, Mathias_Bauer
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description wuyan.ooorg 2008-08-01 02:58:43 UTC
1. New a document(swriter,scalc...)
2. show the Navigator Window (hit key 'F5')
3. Click button 'Drag Mode'(or 'Heading Levels Shown') to show the popup menu,
then hit key 'ESC'
4. OOo will crash
Comment 1 Rainer Bielefeld 2008-08-01 05:35:52 UTC
I checked with "2.4.1  Multilingual version German UI WIN XP:
[680m17(Build9310)]"  and can NOT confirm the reported crash.

@wuy:
What WIN versions did you test with what OOo localization?
Only WRITER crashes, not CALC?
Comment 2 wuyan.ooorg 2008-08-01 06:15:10 UTC
@rainerbielefeld: Sorry,:-( I have to correct step 3:
...then hit key 'F5'

the OOo will crash, I tested Writer and Calc(en_US) on Windows XP.
Comment 3 Rainer Bielefeld 2008-08-01 07:14:21 UTC
I checked with "2.4.1  Multilingual version German UI WIN XP:
[680m17(Build9310)]"  and can confirm the reported crash when I press 'F5' in
step 4.

Same with "Ooo-dev 3.0.0 Beta Multilingual version English UI WIN XP: [300m27
(Build9336)]".

The crash only occurs if the Navigator window is not docked.

I created a crash report and will contribute report ID asap.
Comment 4 Rainer Bielefeld 2008-08-01 13:06:46 UTC
Crash report ID is rkuu4uc
Comment 5 Mathias_Bauer 2008-11-05 14:24:57 UTC
Thanks for the confirmation, I'll take over.
Comment 6 Mathias_Bauer 2009-02-12 14:33:57 UTC
It seems that something has changed in VCL recently.

It turned out that VCL does not tell us that a popup window is open in the
dialog and so we can't react to it. A fix would be more effort than I would like
to see in a late fix. As the situation is understandable and can be avoided
easily, I would like to move the target to 3.2  and implement a solution based
on a broader investigation. Comparable problems can be createad by e.g. opening
a modal dialog inside the stylist window.
Comment 7 Martin Hollmichel 2009-02-23 14:58:17 UTC
set target 3.2 and removed from 3.1 blocker list as agreed in the release status
meeting
Comment 8 jr 2009-02-23 15:05:52 UTC
Also reproducable with OOo 3.0.1 Linux (Ubuntu), changing OS
Comment 9 stefan.baltzer 2009-03-11 12:51:32 UTC
*** Issue 100110 has been marked as a duplicate of this issue. ***
Comment 10 safaee1688 2009-03-31 03:06:45 UTC
I successfully replicate the bug on windows XP home Configuration in 680m17
(build:9310).
If an Icon has its popup menu open, we press F5, then OO crashes.
Work around this is to close that popup menu first before hit F5
I think this should be a P3 issue because on special circumstances OO crashes.
Comment 11 Mathias_Bauer 2009-06-03 10:44:08 UTC
As discussed, Window::IsInModalMode() should return TRUE also if a popup window
is open in the window or one of its child windows.

A patch is attached for sfx2/source/appl/childwin.cxx that checks the modal mode
of a window like e.g. the Navigator before allowing to close it.
Comment 12 Mathias_Bauer 2009-06-03 10:45:10 UTC
Created attachment 62744 [details]
patch of sfx2/source/appl/childwin.cxx
Comment 13 philipp.lohmann 2009-06-22 13:56:10 UTC
fixed in CWS vcl103
Comment 14 philipp.lohmann 2009-07-17 13:12:42 UTC
please verify in CWS vcl103
Comment 15 stefan.baltzer 2009-07-20 14:34:12 UTC
Verified in CWS vcl103.
Comment 16 thorsten.ziehm 2009-07-20 14:55:08 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues
Comment 17 thorsten.ziehm 2009-07-20 15:35:05 UTC
Sorry this issue was wrongly closed. This issue will be reopened automatically.
And will be set after that back to fixed/verified.
Comment 18 thorsten.ziehm 2009-07-20 15:39:39 UTC
Set to state 'fixed'.
Comment 19 thorsten.ziehm 2009-07-20 15:43:58 UTC
Set back to state 'verified/fixed'.

Again. Sorry for the mass of mails.