Issue 92393 - bibliography dialog combobox is not sorted
Summary: bibliography dialog combobox is not sorted
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: DEV300m21
Hardware: PC All
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: dnwilson
QA Contact:
URL:
Keywords: needmoreinfo, oooqa
: 99651 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-08-01 21:09 UTC by macias
Modified: 2017-05-20 10:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
bibliography entry dialog (30.05 KB, image/png)
2008-08-05 12:03 UTC, macias
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description macias 2008-08-01 21:09:21 UTC
I really cannot imagine how am I supposed to pick up an item from let's say 50 
entries. _Unsorted_ entries.
Comment 1 michael.ruess 2008-08-04 07:00:57 UTC
Reassigned to ES.
Comment 2 eric.savary 2008-08-05 07:28:43 UTC
Which dialog and control are you exactly talking about?
Comment 3 macias 2008-08-05 12:03:03 UTC
Created attachment 55560 [details]
bibliography entry dialog
Comment 4 macias 2008-08-05 12:04:04 UTC
The combobox at the bottom.
Comment 5 eric.savary 2008-08-05 12:22:08 UTC
Duplicate of issue 4260
See explanation in issue 13009

*** This issue has been marked as a duplicate of 4260 ***
Comment 6 eric.savary 2008-08-05 12:22:24 UTC
closed
Comment 7 macias 2008-08-05 13:22:02 UTC
The other report is about bibliography database, my report is about inserting 
into document entries _from_ this DB. So it is not about managing database 
itself. See the discussion: metadata, database format, ODF format, and so on.
My report does not even touch such topics.

I don't see how this is related to displaying list of entries, I guess 
currently to populate combobox you use
SELECT SHORTNAME FROM BibliographyDB;
and my wish is to change it to:
SELECT SHORTNAME FROM BibliographyDB ORDER BY SHORTNAME;

End of change. 

The other report is about vast change in whole engine, mine is just about 
sorting a combobox. No matter what backend you have you can always present 
data (in "frontend") in random or ordered fashion. So one thing is not 
dependent of another (reopening).
Comment 8 eric.savary 2008-08-05 13:32:44 UTC
Reassigning to DNW to get more info on this.

@DNW: do you already have this issue on your list?
Comment 9 eric.savary 2008-08-05 16:57:55 UTC
Reassigned
Comment 10 michael.ruess 2009-02-27 12:01:52 UTC
*** Issue 99651 has been marked as a duplicate of this issue. ***
Comment 11 jcarberry 2011-04-18 09:13:27 UTC
Agreed that the list ought to be sorted. But note that by typing the text you seek, the list automatically jumps to the next matching entry (which is better than nothing).

However, the Alt+N does NOT put the focus on the combo list, nor does tabbing do it. You must click on it with the mouse.
Comment 12 Edwin Sharp 2014-03-05 13:17:10 UTC
Please specify steps to reproduce bug.
Comment 13 Edwin Sharp 2014-03-19 06:44:00 UTC
No info from author.