Issue 92492 - [MWEx] cannot connect to MediaWiki in options dialog
Summary: [MWEx] cannot connect to MediaWiki in options dialog
Status: VERIFIED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: DEV300m28
Hardware: All Linux, all
: P2 Trivial with 5 votes (vote)
Target Milestone: 4.1.8
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-05 18:43 UTC by andreschnabel
Modified: 2021-06-28 19:54 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.7
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description andreschnabel 2008-08-05 18:43:00 UTC
happens only on Linux, windows is ok.

When trying todefine a new MediaWiki connection, an error ocures that the
connection cannot be established.

It only works if the options dialog is called right after installing the extension!

To reproduce-
- install Mediawiki extension (make sure no other version is installed before
and no setting file is in place)
- open options dialog and add a MediaWiki server connection (you may use
http://wiki.services.openoffice.org/wiki/)
-> connection can be added

- close and restart OOo
- go to tools - options, internet - mediawiki
- edit the existing connection or try to add it a second time
-> error message is displayed - connection cannot be stablished.


when started from command line, i get the following trace:
05.08.2008 19:16:26 org.apache.commons.httpclient.HttpMethodDirector
executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request:
Connection refused
05.08.2008 19:16:26 org.apache.commons.httpclient.HttpMethodDirector
executeWithRetry
INFO: Retrying request
05.08.2008 19:16:26 org.apache.commons.httpclient.HttpMethodDirector
executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request:
Connection refused
05.08.2008 19:16:26 org.apache.commons.httpclient.HttpMethodDirector
executeWithRetry
INFO: Retrying request
05.08.2008 19:16:26 org.apache.commons.httpclient.HttpMethodDirector
executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request:
Connection refused
05.08.2008 19:16:26 org.apache.commons.httpclient.HttpMethodDirector
executeWithRetry
INFO: Retrying request
java.net.ConnectException: Connection refused
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
        at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
        at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
        at java.net.Socket.connect(Socket.java:519)
        at java.net.Socket.connect(Socket.java:469)
        at java.net.Socket.<init>(Socket.java:366)
        at java.net.Socket.<init>(Socket.java:240)
        at
org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(Unknown
Source)
        at
org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(Unknown
Source)
        at org.apache.commons.httpclient.HttpConnection.open(Unknown Source)
        at
org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(Unknown
Source)
        at
org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(Unknown Source)
        at
org.apache.commons.httpclient.HttpMethodDirector.executeMethod(Unknown Source)
        at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
        at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
        at com.sun.star.wiki.Helper.ExecuteMethod(Unknown Source)
        at com.sun.star.wiki.WikiEditSettingDialog.DoLogin(Unknown Source)
        at com.sun.star.wiki.WikiEditSettingDialog$1.run(Unknown Source)


jre is Sun JRE, 1.6.0_03
Comment 1 eric.savary 2008-08-05 20:51:03 UTC
to me
Comment 2 andreschnabel 2008-08-05 20:56:30 UTC
happens with extension version number 0.9.3 and 1.0.0
Comment 3 eric.savary 2008-08-08 11:50:50 UTC
I cannot reproduce your problem.
(SuSE 10.1 / OOo m28 / MWEX 1.0)
After restarting the URL can be edited and confirmed. Connection re-works.

@MAV: can you read in the java messages what may go wrong?
Comment 4 mikhail.voytenko 2008-08-08 12:54:38 UTC
The exception only says that the connection to the site can not be established.
It is hard to say what going wrong without possibility to reproduce the problem.

I can not imagine how the extension implementation could depend from the time
that has passed since installation.

So I would suspect that something in environment could go wrong, so that the
connection to the site is temporary unavailable. But as I have already mentioned
at the beginning, it is hard to make a conclusion without possibility to
reproduce the problem.
Comment 5 andreschnabel 2008-08-08 13:09:34 UTC
hmm .. maybe an issue with debian base systems. Sophie got the same problem
(afaik she is using ubuntu), I am using KUbuntu. There is a comment at the
extension for the sam problem - on ubuntu.

I'll test again with suse linux later today.
Comment 6 andreschnabel 2008-08-12 18:54:45 UTC
same problem using SuSE 10.3, OOO300m1 (german langpack installed), Sun Wiki
Publisher 1.0

I can add / edit a connection right after the extension was installed.
After a restart of OOo, I get an connection error for the same task.

Java output on console is the same.
Comment 7 roman 2008-10-23 01:59:29 UTC
With OOo 3.0 (vanilla) and (K)Ubuntu 8.04 the bug is exactly the same. I can add
servers in the moment of the installation, but in the new session of OOo, the
process don't work.
Comment 8 lohmaier 2009-02-05 00:51:24 UTC
This seems to be a more general problem with java-based extensions.

Directly after installation, when the extension is run outside the soffice.bin,
the OpenCards extension works fine, but after OOo is restarted, it just hangs.
Just use OpenCards|About - the first time it works just fine, but then it will
hang - the dialog will still show up, but will not close anymore (using
jdk1.6u11, on linux)
http://opencards.info/

raising prio, as this has quite an impact on extensions, and has been confirmed
by at least three different persons with different setups
Comment 9 eric.savary 2009-07-26 13:23:55 UTC
Hi all!

Could you please give the current Wiki Publisher (1.1) a try?
http://extensions.services.openoffice.org/project/wikipublisher

Please test this with a current 3.1 or better, a dev build 3.2.

Thanx!
Comment 10 Keith N. McKenna 2018-02-09 17:09:42 UTC
This now appears to be a problem in Windows also and I expect macOS though I do not have a mac to test it. I have tested it with Windows 7 64 bit and Windows 10 64 bit. My suspicion is that part of the problem may be that our mwiki know uses https rather than http for its connection.

I would like to see this resolved as it could be a boon in trying to revive the documentation effort.
Comment 11 Matthias Seidel 2020-10-28 12:27:00 UTC
The Wiki Publisher we build with AOO418 seems to be functional again:

https://home.apache.org/~mseidel/wiki-publisher.oxt

Should we provide it via:

https://extensions.openoffice.org/

when the official release has happened?
Comment 12 Matthias Seidel 2020-11-01 23:23:59 UTC
I could successfully connect to our Wiki server and update pages on Windows and Ubuntu.

Setting this as fixed now.

For the time being the extension will be here:
https://home.apache.org/~mseidel/wiki-publisher.oxt

Later I will upload it to https://extensions.openoffice.org
Comment 13 Keith N. McKenna 2021-06-28 19:34:13 UTC
(In reply to Matthias Seidel from comment #12)
> I could successfully connect to our Wiki server and update pages on Windows
> and Ubuntu.
> 
> Setting this as fixed now.
> 
> For the time being the extension will be here:
> https://home.apache.org/~mseidel/wiki-publisher.oxt
> 
> Later I will upload it to https://extensions.openoffice.org

Matthias;

I am marking this verified fixed, and it should be uploaded to the extensions site. As soon as it is uploaded, I will set it as closed.
Comment 14 Matthias Seidel 2021-06-28 19:54:49 UTC
Agreed!

Although I have no idea if we have an official AOO account on extensions.o.o to upload it.