Issue 92541 - Line height too small to display characters in View Design window
Summary: Line height too small to display characters in View Design window
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.0 Beta 2
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
: 92540 (view as issue list)
Depends on:
Blocks: 84405
  Show dependency tree
 
Reported: 2008-08-07 08:09 UTC by redflagzhulihua
Modified: 2009-04-09 14:04 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
see the third collumn of the first row. Actually goes into any cell will decrease the visible line height. (37.61 KB, image/png)
2008-08-07 08:28 UTC, amy2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description redflagzhulihua 2008-08-07 08:09:03 UTC
My OS is Fedora 8.

See the attachment:
Choose a field in the field list or go into a cell in the first row, The line 
height is too small to complelely display the characters.
Comment 1 amy2008 2008-08-07 08:28:53 UTC
Created attachment 55624 [details]
see the third collumn of the first row. Actually goes into any cell will decrease the visible line height.
Comment 2 amy2008 2008-08-07 08:30:21 UTC
see the third column of the first row. Actually goes into any cell IN FIRST ROW
will decrease the visible line height.
Comment 3 christoph.lukasiak 2008-08-12 11:47:03 UTC
may you take any other window and cover the bad repainted area -> after taking
away this window: does the repaint mismatch still exist?
Comment 4 christoph.lukasiak 2008-08-12 11:55:23 UTC
set keyword 'needmoreinfo'
Comment 5 redflagzhulihua 2008-08-13 09:29:25 UTC
Hi clu,
This is not a repaint issue. I mean the first row in the grid.
Active a cell in first row will reduce the visible line height of the cell.

This only reproduce under Linux. (I'm using Fedora8)
Comment 6 drewjensen.inbox 2008-08-13 17:02:05 UTC
I was able to reproduce this under Ubuntu 8.0.4 (gnome) using OOO300_m2

It required this specific sequence:

Open a new Query design window
Add a table
DO NOT select a field by double clicking any thing in the table field list -
instead select a field from the drop down combobox of the first (Field) row in
the bottom grid.
Click into the second row (Alias)
Type in any text and then TAB
The contents of the third row (Table) is now displayed quite poorly..as in the
attached screen shot.

If you just click into the third row (Table) it cleans right up when the combo
box for table names is displayed. 

Also this doesn't happen if you select a field from the table by double clicking it.
Comment 7 redflagzhulihua 2008-08-14 02:58:29 UTC
I'm sorry, the attachment contains 2 issues:
1. Line height of the text in the active cell in row 1 reduced
2. Refresh problem in row 3

I described the 2nd issue in issue 92540. And this issue report the first issue.

@atjensen: I'm sorry for making you confused with the attachment. Will you 
please add your comment in issue 92540? Thank you.
Comment 8 christoph.lukasiak 2008-09-24 11:52:51 UTC
i can repro that like described
Comment 9 Frank Schönheit 2008-09-24 12:10:52 UTC
fs->oj: please take this one
Comment 10 ocke.janssen 2008-11-10 08:15:02 UTC
Fixed in cws dba32a
Comment 11 ocke.janssen 2008-11-28 08:00:01 UTC
The height of the rows is now defined by the theme itself.

Please verify. Thanks.
Comment 12 marc.neumann 2008-12-05 10:43:56 UTC
verified in CWS dba31f

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba31f
Comment 13 amy2008 2009-04-03 08:10:07 UTC
Verified in OOo310m8 on Fedora9
Closing
Li Meiying
Comment 14 ocke.janssen 2009-04-09 14:04:09 UTC
*** Issue 92540 has been marked as a duplicate of this issue. ***