Issue 92622 - Opening file with special character in filename
Summary: Opening file with special character in filename
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0 Beta 2
Hardware: PC Windows Vista
: P2 Trivial with 22 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2008-08-09 21:50 UTC by juice_malone
Modified: 2014-02-16 16:20 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

3.0 beta file opening error (203.86 KB, image/png)
2008-08-09 21:51 UTC, juice_malone
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description juice_malone 2008-08-09 21:50:35 UTC
I've found that OOo 3.0 beta 2 cannot open an existing file with a special
character in the filename (i.e., the "é" in resumé).  It appears that the
program cannot interpret the character, and thus subsequently thinks that file
does not exist.  (See - )  I've
tried opening via 1) the file -> open command, 2) the open button (on the
toolbar), and 3) through the 'Open a document...' button on the 'Welcome to' screen.

Also, a similar issue occurs when you try to save a new file with a special
character in the filename.  If you try to save a file (odt, ods, etc) with a
special character in the filename, the resulting saved file loses that special
character (to be replaced by another, undesired character), and the file
extension is not appended.

These issues seem to apply to all components of OOo: Writer, Calc, etc.  This
does not apply to OOo 2.4.1 (or previous versions?).  It only appears to happen
in 3.0 beta 1 and 3.0 beta 2.

Please also note that this is while using the version.  I do
not imagine there to be any difference in the 'installed' version, however.
Comment 1 juice_malone 2008-08-09 21:52:00 UTC
Created attachment 55668 [details]
3.0 beta file opening error
Comment 2 alexylee 2008-09-30 10:57:29 UTC
This happend also by Mac OS X 10.5.
RC1, RC2 and RC3 all have reading special character file name (such as Chinese
and German umlauts) problem.
Comment 3 moettti 2008-12-11 20:16:11 UTC
*** Issue 92622 has been confirmed by votes. ***
Comment 4 johnopen 2009-03-15 10:25:47 UTC
I also encountered this issue in 3.0.1 on Mac OS X 10.5. I find
it especially troublesome that the error message that is given "{file path} does
not exist" is completely bogus and does not help people at identifying the
problem at all.

Not being able to open files with special characters is a very serious issue. In
some countries the majority of the documents have special characters in it, and
many people who are not able to open their documents will not be able to find
out what the problem is and simply stop using

Comment 5 mirek21 2009-03-17 18:55:38 UTC
The problem still exists - Mac OS X Leopard 10.5.6, OOO 3.1 m5... Extremely
annoying :-(
Comment 6 peterplomb 2009-10-08 13:34:55 UTC
This issue still exists; Mac OS X 10.6 Snow Leopard + OoO 3.1
Comment 7 bobcloclimar 2009-10-12 09:36:13 UTC
When i try to save a french document with ' é ' letter or any other with accent,
in finder, it doesn't work. When saving a document with a é or è, the filename
change itself to xxx%E9xxx where 'x' is a letter without accent and %E9 is for é...
The bug occurs in last version at the time of writing OOo 3.1
Comment 8 Martin Hollmichel 2010-03-05 11:39:03 UTC
checked this on XP and Win7 with OOo 3.2, does this still occur in 3.2 on Mac ?
Comment 9 bobcloclimar 2010-03-05 17:03:28 UTC
Yes, the bug still occurs in 3.2
Comment 10 tpisto 2010-07-15 20:31:38 UTC
Bug still occurs in 3.2.1. in Mac OS X. I'm (or the guys who are sending document to me) using 
scandinavian characters äöåÄÖÅ - and OOo cannot open those. This bug renders the usage of the software 
really difficult.
Comment 11 terjeka 2011-01-10 13:59:15 UTC
OpenOffice 3.2.0 on Ubuntu 10.04 - still having trouble with norwegian characters 
in filenames. Any hope for a bugfix soon?

Comment 12 owf 2011-05-22 18:55:18 UTC
OOo 3.3.0 (build 9567) on OSX, still not fixed.

I don't understand how this cannot have been fixed yet after 3 and a half years. It's a massive bug for writers of non-English languages.
Comment 13 Jan Høydahl 2012-10-26 11:25:37 UTC
This works for me, AOO 3.4.1, Mac OSX.
Comment 14 Anónima 2013-07-01 18:59:53 UTC
Same problem with latest update.  I even have the Spanish version of oo, but Spanish file names produce the errors or file name changes previously described.

Has there been ANY official acknowledgement of this problem.  I recall earlier versions when this was not an issue.