Issue 93091 - Remove filter doesn't work well
Summary: Remove filter doesn't work well
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: DEV300m28
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: oooqa, regression
: 96442 (view as issue list)
Depends on:
Blocks: 84405 96442
  Show dependency tree
 
Reported: 2008-08-25 09:53 UTC by redflagzhulihua
Modified: 2013-08-07 15:14 UTC (History)
5 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A filter sample (6.77 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-08-25 09:53 UTC, redflagzhulihua
no flags Details
A patch about issue 93091. (1.18 KB, text/plain)
2009-01-21 07:41 UTC, gaozm
no flags Details
A new patch about issue 93091. (660 bytes, text/plain)
2009-02-16 09:12 UTC, gaozm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description redflagzhulihua 2008-08-25 09:53:01 UTC
1. open the attached document
2. select column A
3. Data->Filter->Standard filter...
4. Set a condition, e.g.: Column A < 56    //show filtered rows
5. Data->Filter->Remove filter

the hidden rows do not show up, except one row above the data area.
Comment 1 redflagzhulihua 2008-08-25 09:53:59 UTC
Created attachment 55986 [details]
A filter sample
Comment 2 redflagzhulihua 2008-08-25 09:56:58 UTC
This worked well in OOo2.4, so I add keyword "regression".
Comment 3 Rainer Bielefeld 2008-11-22 10:19:44 UTC
The problem is caused by the empty cells in the filter range. If you fill them
with some character or number, all will work as expected. Seems to have the same
roots as Issue 96442.

Comment 4 gaozm 2009-01-21 07:41:03 UTC
Created attachment 59548 [details]
A patch about issue 93091.
Comment 5 niklas.nebel 2009-01-23 10:55:27 UTC
Perhaps ScDBFunc::GetDBData should be modified instead. Could you check where it
is used, and if all usages would still work if GetDBData is changed?
Comment 6 gaozm 2009-02-16 09:12:31 UTC
Created attachment 60187 [details]
A new patch about issue 93091.
Comment 7 niklas.nebel 2009-02-20 18:46:36 UTC
I added the last patch to CWS "calc49".
Comment 8 niklas.nebel 2009-03-04 17:00:08 UTC
correct owner
Comment 9 niklas.nebel 2009-04-03 08:55:19 UTC
reassigning to QA for verification
Comment 10 oc 2009-05-12 08:54:44 UTC
verified in internal build cws_calc49
Comment 11 amy2008 2009-06-02 08:40:53 UTC
Verified in DEV300m49 on WinXP
Closing
Comment 12 niklas.nebel 2010-07-30 11:53:53 UTC
*** Issue 96442 has been marked as a duplicate of this issue. ***