Issue 93544 - Inserting a frame with text leads to a wrong layout
Summary: Inserting a frame with text leads to a wrong layout
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.4.1
Hardware: PC Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-06 18:02 UTC by cniehaus
Modified: 2017-05-20 11:25 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
This screenshot shows the issue. (17.73 KB, image/png)
2008-09-06 18:04 UTC, cniehaus
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cniehaus 2008-09-06 18:02:34 UTC
1. Enter a longer text.
2. Mark the text.
3. Insert a new frame (Insert -> Frame).
4. Accept all defaults (just hit "Ok")

This leads to a very long frame / textbox which should be much wider. In my 
opinion the default settings of a text frame are wrong. 

I am doing these four steps quite often and every single time I need to 
readjust the frame. I guess the settings should default to a width which is 
about the width of the page minus the margins.
Comment 1 cniehaus 2008-09-06 18:04:19 UTC
Created attachment 56284 [details]
This screenshot shows the issue.
Comment 2 cniehaus 2008-09-07 09:46:31 UTC
I need to rephrase:

"I guess the settings should default to a width which is 
about the width of the page minus the margins."

The default should simply be to activate the automatic width checkbox in the 
dialog. That fixes the misbehaviour. It is just that Joe User might not find 
it and that I keep forgetting to check the box.
Comment 3 michael.ruess 2008-09-08 12:55:54 UTC
When inserting a frame for selected text, the width default should be a better
one, e.g. a value which is somehow derived from the amount of selected text.
Comment 4 cniehaus 2010-05-11 17:08:55 UTC
Still valid three versions of OpenOffice later (3.2).

I wonder why this is only P3, this happens to me at least once or twice a day
and I doubt I am the only one...

PS: I am a software-developer myself and know not everybody likes these pings on
bugreports.
Comment 5 Oliver-Rainer Wittmann 2010-05-12 08:12:48 UTC
od->cniehaus:
No problem on pinging on issues - it shows which issues are still valid and
hurts much.

I will have a deeper look at this issue in the next days, because I am
wondering, why the width property from the Frame Style "Frame" is not used, when
inserting a new frame.
If this would work, then each user can easily adjust the default width, until a
better built-in default behavior is implemented.
Comment 6 Marcus 2017-05-20 11:24:32 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 7 Marcus 2017-05-20 11:25:55 UTC
Reset assigne to the default "issues@openoffice.apache.org".