Issue 93836 - Filename in Save As not containing filename for existing files
Summary: Filename in Save As not containing filename for existing files
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0 RC1
Hardware: PC Windows Vista
: P2 Trivial (vote)
Target Milestone: OOo 3.0
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa, regression
Depends on:
Blocks: 88888
  Show dependency tree
 
Reported: 2008-09-12 18:48 UTC by per.ooo
Modified: 2009-01-13 09:21 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description per.ooo 2008-09-12 18:48:28 UTC
Hi,

This is OpenOffice.org 3.0 RC1 tested on Windows Vista.

When selecting "Save As" for any document, the Filename field is not filled in
with the filename that the document is currently saved with (as it works on XP).

Repro:
1. Open a new Writer document.
2. Type some text and save.
3. Click Save As.

Expected behaviour:
The Filename field in Save As is pre-filled with the current filename.

Actual behaviour:
The Filename field in Save As is empty.
Comment 1 per.ooo 2008-09-12 19:01:06 UTC
Updated Repro:
1. Create a new Writer document.
2. Type some text and save.
3. Click Save As.
Comment 2 andreschnabel 2008-09-13 12:02:46 UTC
verified on Vista, using OOo3.0RC1 GErman localized build.

the description is still not correct, the critical piont is step 1:

1. open an existing file
2. change the content
3. click "Sav as"

-> file name is not pre-set


worked in 2.4.1
Comment 3 Olaf Felka 2008-09-13 12:18:21 UTC
setting target accordingly
Comment 4 mfn 2008-09-13 14:24:19 UTC
Hi,

I have another bug thats passibly associated with this one.

When opening an existing file, the filename is lost.

Repro:
1. Open existing file
2. Take a look at the Titlebar
3. Try to save changes via File -> Save

OO.org 3.0 rc1 german localized build
Comment 5 vitriol 2008-09-14 08:48:06 UTC
The native file dialog has many big problems on Win Vista, i.e. the option "Save
with password" in not present, and the dialog in not modal.
Comment 6 per.ooo 2008-09-14 10:43:36 UTC
According to author of patch in i91869, the patch solves many things, including
the problem subject in this issue.

Setting dependent on i91869.
Comment 7 thorsten.martens 2008-09-15 09:37:37 UTC
TM->HRO: As decided with MH, this is a showstopper for 3.0
Comment 8 hennes.rohling 2008-09-15 10:18:10 UTC
Added to CWS hro38
Comment 9 per.ooo 2008-09-15 13:55:50 UTC
@hro,

is this issue solved with or without the patch in i91869?
Comment 10 hennes.rohling 2008-09-15 19:20:28 UTC
It just fixes this issue. I only implemented the missing Stuff for
VistaFilePicker::setDefaultName

Comment 11 hennes.rohling 2008-09-16 09:11:10 UTC
Reassigned for verification.
Comment 12 thorsten.martens 2008-09-17 14:01:02 UTC
checked and verified in cws hro38 -> OK !
Comment 13 hennes.rohling 2008-09-22 11:37:37 UTC
Removed dependency to 91869
Comment 14 mfn 2008-09-22 14:26:49 UTC
On WinXP SP3 the bug is still active. When openinig a file from explorer with a
double click the Titlebar in Openoffice says Unbenannt-X (Unknown-X in english).

Win XP SP3
OOorg 3.0.0 RC2 german localization
Comment 15 Mechtilde 2008-09-24 15:57:00 UTC
This seems to be fixed

but:

If you export to XHTML you get something like

test.html;*.xhtml
Comment 16 Mechtilde 2009-01-13 09:21:13 UTC
verified in 300_m12 under Vista -> closed