Issue 93842 - Docx: drawing textboxes imported with wrong size & position
Summary: Docx: drawing textboxes imported with wrong size & position
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOO300m5
Hardware: Unknown All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 94102 95003 96384 97844 100384 101107 107295 108922 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-09-12 19:21 UTC by safway
Modified: 2017-05-20 11:18 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Example File (442.49 KB, application/msword)
2008-09-12 19:22 UTC, safway
no flags Details
What I see (243.33 KB, image/jpeg)
2008-09-12 19:22 UTC, safway
no flags Details
What I expect to see (236.21 KB, image/jpeg)
2008-09-12 19:23 UTC, safway
no flags Details
Word97 with MS FileFormatConverter (47.94 KB, text/plain)
2008-10-30 20:34 UTC, jmiykal
no flags Details
OOo3 (non-beta) (26.15 KB, text/plain)
2008-10-30 20:35 UTC, jmiykal
no flags Details
The miscreant document itself (706.36 KB, text/plain)
2008-10-30 22:12 UTC, jmiykal
no flags Details
the table format is failed to be displayed in OOo 3.0 (23.87 KB, text/plain)
2008-11-20 06:13 UTC, mwu4
no flags Details
a normal table format display (40.50 KB, text/plain)
2008-11-20 06:14 UTC, mwu4
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description safway 2008-09-12 19:21:06 UTC
Environment: Testing MS Office 2007 files using OO.o 3.0 rc1 (build OOO300_m5)

Issue: Text boxes from imported OOXML files are in random places within the
document.

Notes: See attached file and screenshot.
Comment 1 safway 2008-09-12 19:22:10 UTC
Created attachment 56498 [details]
Example File
Comment 2 safway 2008-09-12 19:22:43 UTC
Created attachment 56499 [details]
What I see
Comment 3 safway 2008-09-12 19:23:19 UTC
Created attachment 56500 [details]
What I expect to see
Comment 4 michael.ruess 2008-09-15 15:30:00 UTC
MRU->HBRINKM:  see attached OOXML document. The drawing objects are all imported
with minimum size and located in the upper left of the text area.
Comment 5 michael.ruess 2008-09-22 11:13:53 UTC
*** Issue 94102 has been marked as a duplicate of this issue. ***
Comment 6 Armin Le Grand 2008-10-15 10:16:53 UTC
AW: I guess this one was added to aw058 by error...? Removing from CWS...
Comment 7 michael.ruess 2008-10-16 15:42:55 UTC
*** Issue 95003 has been marked as a duplicate of this issue. ***
Comment 8 jmiykal 2008-10-30 20:31:03 UTC
Hopefully I commented and attached in the right order (the note under "Create a
new attachment" makes me wonder).

Image "Should be" shows document opened by Word 97 with MS FileFormatConverter
-- not perfect, but shows the idea.

"Bad docx" is same doc in OOo 3.0, textboxes all jammed into upper right corner,
as well as both graphics completely transparent in white area of page.
Comment 9 jmiykal 2008-10-30 20:34:49 UTC
Created attachment 57592 [details]
Word97 with MS FileFormatConverter
Comment 10 jmiykal 2008-10-30 20:35:28 UTC
Created attachment 57593 [details]
OOo3 (non-beta)
Comment 11 jmiykal 2008-10-30 22:11:32 UTC
And the next attachment is the document itself; supposed to be like 4 pages
long, whereas in OOo (and 97/converter) it's only the first page.
Comment 12 jmiykal 2008-10-30 22:12:34 UTC
Created attachment 57598 [details]
The miscreant document itself
Comment 13 mwu4 2008-11-20 06:08:56 UTC
There are two files attached; one is a docx file, another is a doc file
converted from the docx file by Office 2007. When we open the docx file with OOo
3.0, the table format is disappeared while the table is displayed normally in
the doc file. It is seemed the same bug related to this issue 93842. Please
check to see what the problem is and correct it. Thank you.
Comment 14 mwu4 2008-11-20 06:13:18 UTC
Created attachment 58132 [details]
the table format is failed to be displayed in OOo 3.0
Comment 15 mwu4 2008-11-20 06:14:29 UTC
Created attachment 58133 [details]
a normal table format display
Comment 16 michael.ruess 2008-11-21 08:54:00 UTC
*** Issue 96384 has been marked as a duplicate of this issue. ***
Comment 17 cactuscomputing 2008-12-02 17:38:15 UTC
Will this important issue be fixed in 3.0.1? 

My company has me looking at alternatives for Office 2007 support, since our
customers will not accept current Open Office output due to bugs such as this
one. My company nearly dropped Open Office entirely. It was only kept because
licensing terms could not be agreed with the supplier of the alternative
technology.  
Comment 18 michael.ruess 2009-01-08 13:33:25 UTC
*** Issue 97844 has been marked as a duplicate of this issue. ***
Comment 19 michael.ruess 2009-03-20 15:09:11 UTC
*** Issue 100384 has been marked as a duplicate of this issue. ***
Comment 20 adamprince 2009-03-24 14:45:53 UTC
I have the same problem. I downloaded novell version and used the extension 
for .docx. This helped some but the program made all my files with ruled lines. 
Like a ruled piece of paper. if i changed the formatting to endnote. The ruled 
lines disappeared. However the relation of text boxes to words continues to be 
slightly wrong and requires some manual reformating.
Comment 21 michael.ruess 2009-04-15 17:12:11 UTC
*** Issue 101107 has been marked as a duplicate of this issue. ***
Comment 22 michael.ruess 2009-11-30 12:29:41 UTC
*** Issue 107295 has been marked as a duplicate of this issue. ***
Comment 23 dawnlight 2009-11-30 19:29:26 UTC
There's a bounty on this bug:
http://www.fossfactory.org/project/p190
Comment 24 cedric.bosdonnat.ooo 2009-12-01 08:30:09 UTC
Progresses on this bug have already started. Please have a look at the
writerfilter32bugfixes01 CWS. There will be other CWSes for the docx import, one
of them is writerfilter07.

Anybody wanting to work on that bug should contact either myself or hbrinkm.
Comment 25 michael.ruess 2010-02-04 12:40:37 UTC
*** Issue 108922 has been marked as a duplicate of this issue. ***
Comment 26 Marcus 2017-05-20 11:18:17 UTC
Reset assigne to the default "issues@openoffice.apache.org".