Issue 93881 - Scientific number entry: Entering 1.8e6 in a field in calc enters it as text not 1.8million
Summary: Scientific number entry: Entering 1.8e6 in a field in calc enters it as text ...
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 3.0 RC1
Hardware: PC (x86_64) Windows Vista
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact: Yurggent Alfredo Chable Torrez
Depends on:
Reported: 2008-09-14 13:40 UTC by luvirini
Modified: 2013-02-10 23:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 3.4.1
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description luvirini 2008-09-14 13:40:51 UTC
Entering 1.8e6 in a field in calc enters it as text "1.8e6" not 1.8million

Locale set to Finland, that has the default decimal separator ","  but setting
for both currency and numbers have decimal separator in windows is set to "."

To get 1.8 million need to enter 1,8e6  thus OOo 3.0RC1 seems to ignore the
operating system setting for decimal separator.

Operating system is Windows Vista basic SP1 x64 english.

Doing the same in Open Office 2.3 under Windows Xp, works correctly. (That is
entering 1.8e6 with locale set to Finland and decimal separator to "." gives 1.8
million in the cell)
Comment 1 luvirini 2008-09-14 15:32:52 UTC
Installed 2.4.1 on the vista computer and getting same behavior. So likely the
problem is in getting the decimal separator from Vista as compared to XP.
Comment 2 conte4313 2009-03-27 05:01:57 UTC
I have attempted to enter both 1.8e6 and 1,8e6 under both Finnish and
Default(English) settings under Tools->Language under Windows Vista basic x64
and XP SP2, (both with Open Office v 3.0) and Ubuntu Linux 8.10 (Open Office v
2.0) and I get the same results for all of them as follows:

Locale Setting = Default(English) -> 1,8e6 = #NAME?  &  1.8e6 = 1800000

Locale Setting = Finnish          -> 1.8e6 = #NAME?  &  1,8e6 = 1800000  (except
for Vista, it displays the result as 1,80E+006 in the grid, but it's shown as
1800000 in the formula bar, weird...)

These were both tried with and without the delimiter option being checked, and
with and without the exponent (e6) part.

Based on the appropriate delimiter stated for these locales, should these not be
correct? Also, was the result you saw actually shown as "1.8 million" and not

The delimiter was indeed set for "," for Finnish along with other European
Language Locale settings I've tried and they all displayed the same way. The
same goes for the Default (English) and other (Asian) countries with their
delimiter set to "." (i.e. Chinese, Japanese)

As far as I'm concerned this is acting accordingly, whereas you seem to claim
Finish locale has "." as their delimiter but you get two different responses
from different operating systems.

Could you provide more specific steps on how I could reproduce this bug?

Some further testing ideas could involve seeing the effect of proper number
formatting for currency values instead of normal numbers.
Comment 3 luvirini 2009-03-27 05:57:56 UTC
Steps to get error on Vista:
Step 1:
Goto to locale settings Format tab and set locale to Finnish(Finland)
Step 2:
Select customise this format
Step 3:
Change decimal symbol field to "." and apply
Step 4:
Start Openoffice Calc(have tested with 2.4.1 and 3.0.0)
Step 5:
Type 1.8e6 in A1
Step 6:
Select A1 Cell and See the sum=0 in lower right corner
Step 7:
Type 1,8e6 in A1
Step 8:
Select A1 Cell and See the sum=1,80E+006 in lower right corner
Optional step 9:
Goto Regional settings and check that the decimal separator is indeed a "." 

On My XP computer setting the locale to Finland and decimal separator to "."
works fine with Calc. (have used that setup for years)
Comment 4 orcmid 2013-02-02 18:36:52 UTC
This is not necessarily a bug, as already mentioned.

I opened a fresh spreadsheet in Apache OpenOffice 3.4.1 Calc.  (My installation is en_US and it is on Windows XP SP3 also en_US.  I have not changed the decimal separator anywhere.

In cell A1 I entered "1.8e6" (without the quotes in all cases here).  The cell was presented as "1.80E+006" and the value shown in it when I put the mouse over the cell is "1800000".   Notice that the formatting and the value for the cell were determined by default, based on what I entered.

In cell B1, I entered "=1.8e6".  This *displays* as "1800000" and the value of the cell is shown as "=1800000".

In column C I set the cell format of all cells as Text.  In cell C1 entered "1.8e6" again and the result is "1.8e6" left justified.

For good measure, I entered "=1.8e6" in cell C2 and the value shown is "=1.8e6".  There is no way to over-ride an existing cell format of text unless the format is changed.

Now, a cell can easily have its format default to text by incorrect entry of a number or any previous entry being of format text.  Then putting "1.8e6" in the cell will result in that being taken as text, not a number.  Having made an entry using a decimal point that is not recognized could also have the effect of defaulting the cell format.

With regard to the settings for decimal separator, it is valuable to check Tools | Options | Language Settings | Languages (as internationalized) for what is being used as the "Decimal Separator Key" and also what is set as the User interface and the Locale Setting languages.  According to the help, this determines what is entered when the Numeric Pad "." key is pressed.  So another variation is between using the "." and "," keys and using the Numeric Pad decimal key.  What fun.

To confirm a bug, it is going to be necessary to control these variations and see what then occurs.
Comment 5 Yurggent Alfredo Chable Torrez 2013-02-04 00:38:35 UTC
I just check this in windows 7 with AOO 3.4.1 and is the same.
When i wrote in the cell "1.8e6" this was changed to 1.80E+006 and in the rod the result is 1800000.

Yurggent Alfredo.