Issue 94006 - SRB: errors in executing a report, which are caused by errors in executing the row set, are not propagated to the user
Summary: SRB: errors in executing a report, which are caused by errors in executing th...
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: ReportBuilder (show other issues)
Version: OOO300m6
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: ocke.janssen
QA Contact: issues@dba
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2008-09-17 20:38 UTC by Frank Schönheit
Modified: 2008-10-28 13:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (17.41 KB, application/vnd.sun.xml.base)
2008-09-17 20:38 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2008-09-17 20:38:26 UTC
- open the attached database document
- open the contained report for editing
- execute the report from within the report designer
=> a message box pops up, saying "An error occurred while creating the report".
   There is a "More" button in this dialog, but pressing this just opens another
   dialog which does not have any useful information for the user.

The root cause is that the SQL statement which the report is based on is
invalid. In this case, it is "slightly" invalid in that the table which it
refers does not exist (anymore). However, the user is not given *any* clue about
this root cause.

Since the underlying objects (the RowSet, in particular) are well able to raise
a better error message, which helps the user in identifying the root cause, it
seems that this "better" error message is somehow lost. It should be propagated
to the user.
Comment 1 Frank Schönheit 2008-09-17 20:38:49 UTC
Created attachment 56595 [details]
document to reproduce the bug case
Comment 2 ocke.janssen 2008-10-28 13:04:13 UTC
Already fixed in cws dba31c
Comment 3 Frank Schönheit 2008-10-28 13:35:41 UTC
even already fixed in DEV300m34
Comment 4 Frank Schönheit 2008-10-28 13:36:18 UTC
closing