Issue 94007 - Slideshow crashes on exit (multi-screen)
Slideshow crashes on exit (multi-screen)
Status: RESOLVED FIXED
Product: gsl
Classification: Code
Component: code
current
Unknown All
: P3 trivial (vote)
: AOO 4.0
Assigned To: Andre
issues@gsl
:
: 111758 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 21:49 UTC by thb
Modified: 2013-07-10 15:26 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
proposed fix (deleted)
2008-09-17 21:53 UTC, thb
no flags Details
Patch Update (deleted)
2011-10-31 10:24 UTC, Andre
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description thb 2008-09-17 21:49:23 UTC
Another incarnation of the "wrong screen number" meme - this time on slideshow
exit. Unfortunately, exiting fullscreen mode moves the window back to the
original screen, with currently no way of handling this in the canvas impls.
Added code disposing canvas in WorkWindow::ShowFullScreenMode(), which does not
help here, too - the sd showwin is some child of it. Current (admittedly hacky)
solution - move the SlideShowImpl disposing _before_ the
StartPresentationMode(FALSE) call in SlideShow::end().

Long-term, we need a msg (also for awt), to the likings of "dispose your system
handles", and the canvas can handle that itself.

Patch follows.
Comment 1 thb 2008-09-17 21:53:47 UTC
Created attachment 56596 [details]
proposed fix
Comment 2 thb 2008-09-17 21:55:14 UTC
@af: any negative implications you're aware of, when moving the dispose call in
SlideShow::end()?
Comment 3 groucho266 2008-09-18 12:57:53 UTC
Looks OK to me.
Comment 4 thb 2010-06-01 10:53:50 UTC
*** Issue 111758 has been marked as a duplicate of this issue. ***
Comment 5 thb 2010-06-01 10:54:49 UTC
@af: sorry for the lag. got a cws I could put this into, by chance?
Comment 6 clippka 2010-06-01 12:58:28 UTC
impress191 should be fine, just wait until tomorrow since sj wants to resync it
to the recent m80
Comment 7 thb 2010-06-01 15:44:25 UTC
@sj/@cl: could one of you commit it then, please, after the merge? Sadly hg does
not allow those easy partial checkouts we did back in the day...
Comment 8 clippka 2010-06-03 11:07:22 UTC
I'm fine with adding the patch to cws impress191 but I like to reproduce it
first. Can you please add a description how the crash is reproducable?
Comment 9 caolanm 2010-06-03 11:11:51 UTC
FWIW I can reproduce it with with a dual screen setup, with gtk vclplug in
operation and the cairo canvas toggled on and the presenter screen installed.
Start any presentation and go full screen. Press escape. Should then die with an
XError.
Comment 10 thb 2010-06-03 11:59:53 UTC
yep. sadly this only manifests under cairo & multiscreen. but apart from rolling
a full-blown "screen nums have changed, drop all your system handles"
infrastructure, there's no other way to fix this.
Comment 11 thorsten.ziehm 2010-09-23 13:20:13 UTC
OOo 3.3 is in showstopper-mode. This issue is too old to be a stopper for the
current release. I change the target to OOo 3.x. Please change the target
accordingly when a fix is near to be integrated into a code line. 
Comment 12 Andre 2011-10-31 10:24:47 UTC
Created attachment 76940 [details]
Patch Update

Updated the patch so that it can be applied again. (and fixed some minor typos in new comments)
Comment 13 Pedro Giffuni 2011-10-31 15:45:27 UTC
It looks like this never was integrated to impress191.

Sending        sd/source/ui/slideshow/slideshow.cxx
Sending        vcl/source/window/wrkwin.cxx
Transmitting file data ..
Committed revision 1195527

Thank you!
Comment 14 Pedro Giffuni 2011-11-07 14:42:57 UTC
Author has expressed he does not want his code included
under an Apache License:

"With the header changes Andrew was making successively
(http://svn.apache.org/viewvc?view=revision&revision=1198285
and http://svn.apache.org/viewvc?view=revision&revision=1198320), I
disapprove application, and subsequent re-licensing of my patch to
AL2."
Comment 15 Pedro Giffuni 2011-11-07 20:17:03 UTC
commit -m "i94007 - Revert r1195527 at author's request."
Sending        sd/source/ui/slideshow/slideshow.cxx
Sending        vcl/source/window/wrkwin.cxx
Transmitting file data ..
Committed revision 1198909.

I will leave the issue open for reference until we have a complete fix.
Comment 16 hdu@apache.org 2012-07-11 12:46:13 UTC
The content of attachment 56596 [details] has been deleted by
    hdu@apache.org
who provided the following reason:

not applicable on request of thb@documentfoundation.org

The token used to delete this attachment was generated at 2012-07-11 12:45:37 UTC.
Comment 17 hdu@apache.org 2012-07-11 12:47:17 UTC
The content of attachment 76940 [details] has been deleted by
    hdu@apache.org
who provided the following reason:

not applicable on request of creator af@a-w-f.de

The token used to delete this attachment was generated at 2012-07-11 12:46:38 UTC.
Comment 18 Andre 2012-07-11 12:50:34 UTC
Thanks Herbert for removing the patches.  Now we can use the idea described in the first comment for fixing this again.
Comment 19 SVN Robot 2012-07-12 09:40:17 UTC
"af" committed SVN revision 1360602 into trunk:
#i94007# Dispose controller earlier when slide show is ended to avoid crash.
Comment 20 Andre 2012-07-12 09:41:05 UTC
Fixed.
Comment 21 hdu@apache.org 2013-07-10 15:26:27 UTC
Update target to version containing the fix