Issue 94148 - In particular .xls: Some Text Boxes text contents 180° rotated
Summary: In particular .xls: Some Text Boxes text contents 180° rotated
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0 RC2
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2008-09-22 08:37 UTC by mareksm
Modified: 2017-05-20 10:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
sample excel document (54.50 KB, application/vnd.ms-excel)
2008-09-22 08:38 UTC, mareksm
no flags Details
Screenshot Comparison (45.24 KB, application/vnd.oasis.opendocument.graphics)
2014-02-13 05:49 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mareksm 2008-09-22 08:37:35 UTC
quite a few of those text boxes from excel created document has vertically
flipped text in them (up-side-down) - see attached sample sheet.
Comment 1 mareksm 2008-09-22 08:38:36 UTC
Created attachment 56699 [details]
sample excel document
Comment 2 Mechtilde 2010-01-02 11:14:10 UTC
@ mareksm

Can you give us more information about the task

Can you reduce the file only to show the problem
Comment 3 mareksm 2010-01-04 19:01:11 UTC
File is already reduced to minimum possible.

Look for example light-green text-boxes -> text is upside-down (shows correctly 
in excel). 

/mareks
Comment 4 Rob Weir 2013-02-02 02:57:57 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 5 Edwin Sharp 2013-07-19 12:50:12 UTC
Text is already flipped in Excel 2010.
Comment 6 Rainer Bielefeld 2014-02-13 05:19:37 UTC
Hm, I can't see any vertically flipped text with MS EXCEL viewer, so I think There is some misunderstanding in Comment 5. I will do some more research
Comment 7 Rainer Bielefeld 2014-02-13 05:47:57 UTC
Reproducible with server installation of "Ooo 3.1.1 German WIN7 Home Premium (64bit) DE [OOO310m19 (Build 9420)]":

1. Open Sample document
2. Watch light green Text boxes. for Example "AutoShape 67" nearby
   BE42
   > Text looks rotated 180°
   > Edit Mode (double click on text box): now text looks correctly
   > After edit mode has been left text rotated again.

Additional Info:
----------------
(a) Has been fixed for
      server installation of "AOO 3.4.0 – German UI / German locale 
     [AOO340m1(Build:9590) - Rev.1327774]" on German WIN7 Home Premium (64bit)"
     own separate user profile
(b) Still reproducible with sever installation of "OOo 3.3.0 English UI
    / German locale [OOO330m20 (Build 9567)]" on WIN7 Home Premium (64bit) DE 
(c) Has been fixed for AOO 3.4.0, but because of incomplete Target Milestone
   selector contents (Bug 123063) I only can select TM = 4.1.0, no correct
   information can be contributed.
(d) Latest confirmation for OOo 3.3.0, but because of incomplete LCo 
    selector (Bug 123063) no correct information can be contributed.
Comment 8 Rainer Bielefeld 2014-02-13 05:49:23 UTC
Created attachment 82573 [details]
Screenshot Comparison

See comment above!
Comment 9 Rainer Bielefeld 2014-02-13 06:46:02 UTC
I will check possible relations to 
"Bug 121494 - mangled text in graphic line rotated 180 degrees"
later