Issue 94242 - Insert "New Slide" Fails To Load At Mouse Position
Summary: Insert "New Slide" Fails To Load At Mouse Position
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: DEV300m60
Hardware: Unknown All
: P3 Trivial with 4 votes (vote)
Target Milestone: OOo 3.2
Assignee: wolframgarten
QA Contact: issues@graphics
Keywords: regression
: 94366 94719 95999 96463 97593 97681 98022 98278 (view as issue list)
Depends on:
Blocks: 99999
  Show dependency tree
Reported: 2008-09-23 17:39 UTC by drichard
Modified: 2017-05-20 10:29 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Tried To Insert Slide Between 1 and 2, went into position 3. (324.77 KB, image/png)
2008-09-23 17:40 UTC, drichard
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drichard 2008-09-23 17:39:07 UTC
When using Impress, you have thumbnails of your slides on the left side.   Let's
say that you have 4 slides.  If you right-mouse click in the thumbnailer tray on
the left between slides 1 and 2 you get a menu option to insert "New Slide".  It
also draws a black line in this position to show you where the slide will be
added.  However, when you select "New Slide", it puts the slide at the bottom in
the last position.  I'll attach a screenshot.
Comment 1 drichard 2008-09-23 17:40:14 UTC
Created attachment 56775 [details]
Tried To Insert Slide Between 1 and 2, went into position 3.
Comment 2 drichard 2008-09-23 17:42:06 UTC
Setting to Linux, cannot confirm other OS's
Comment 3 drichard 2008-09-23 17:46:06 UTC
It happens in Draw as well, so it seems to be in the thumbnail display code.
Comment 4 wolframgarten 2008-09-24 08:16:06 UTC
Reproducible. Reassigned.
Comment 5 wolframgarten 2008-09-29 09:03:58 UTC
*** Issue 94366 has been marked as a duplicate of this issue. ***
Comment 6 cine 2008-10-01 15:38:44 UTC
This is present in m5 and m8 and also on windows.
It is a huge usability issue when making a slideshow, it really should be
release critical for 3.0.
Comment 7 drichard 2008-10-01 15:58:56 UTC
I know that everyone always says their bug is critical, but this one seems like
a showstopper for 3.0 release.  It's almost impossible to build a slide show
from the primary screen.  You have to keep flipping into slide view and moving
the slides into the right order.  You have to do this after each insert of a new
Comment 8 wolframgarten 2008-10-07 07:57:36 UTC
*** Issue 94719 has been marked as a duplicate of this issue. ***
Comment 9 cine 2008-10-09 11:37:21 UTC
OS tag still not updated.
Version tag still not updated.
Please set target to to 3.0, it makes it VERY difficult to make slide shows with
more than a few slides.
Comment 10 wolframgarten 2008-10-09 12:30:44 UTC
Changed target to 3.0.1.
Comment 11 groucho266 2008-10-23 12:25:54 UTC
What happens here is this:
1.  Insertion marker is turned on (black bar)
2. Popup menu is displayed.
3. User selects menu entry or clicks outside of menu.
3a. (optional)  When a menu entry was clicked then schedule associated slot call.
3b. In both cases the menu is hidden. 
4. Insertion marker is turned off.

The asynchronous slot call that is scheduled in 3a is executed after 4.  As a
result the place at which to insert the slide is no longer known and the slide
is inserted at the default location: at the end of the document.

The problem is to come up with a clean and working way to pass the insertion
location to the slide insertion code.
Comment 12 groucho266 2008-10-29 14:55:56 UTC
Before the insertion indicator is hidden but after the context menu is closed,
the slide before the place marked by the insertion indicator is selected.  This
is done anyway in SlotManager::GetInsertionIndex() when the insertion indicator
is still showing.

The only drawback of this solution is that the slide is selected even when the
user closed the context menu by clicking on the background and no slot is executed.

Modified file is sd/source/ui/slidesorter/controller/SlideSorterController.cxx 
Comment 13 groucho266 2008-10-30 10:35:04 UTC
Forgot to mark this issue as fixed.
Comment 14 clippka 2008-11-03 16:20:25 UTC
verified in cws, back to qa
Comment 15 wolframgarten 2008-11-07 14:43:46 UTC
Verified in CWS.
Comment 16 wolframgarten 2008-11-10 07:49:08 UTC
*** Issue 95999 has been marked as a duplicate of this issue. ***
Comment 17 drichard 2008-11-10 13:17:58 UTC
If you have a .so that works with the released 3.0, I would be very happy to put
this into production and have my users test it.  It's better for me to try this
patch than listen to people complain about this when creating Impress documents. :)
Comment 18 wolframgarten 2008-11-10 13:35:57 UTC
The problem is fixed in CWS impress163, which is already approved and will make
its way into the next release (3.0.1).
Comment 19 wolframgarten 2008-11-20 14:46:51 UTC
Tested in m12 . Closed.
Comment 20 wolframgarten 2008-11-23 19:37:44 UTC
*** Issue 96463 has been marked as a duplicate of this issue. ***
Comment 21 Regina Henschel 2008-12-31 12:24:19 UTC
*** Issue 97681 has been marked as a duplicate of this issue. ***
Comment 22 wolframgarten 2009-01-05 13:58:09 UTC
*** Issue 97593 has been marked as a duplicate of this issue. ***
Comment 23 wolframgarten 2009-01-13 09:19:33 UTC
*** Issue 98022 has been marked as a duplicate of this issue. ***
Comment 24 wolframgarten 2009-01-20 12:15:47 UTC
*** Issue 98278 has been marked as a duplicate of this issue. ***
Comment 25 amy2008 2009-06-17 03:55:54 UTC
Can reproduce it from OOo300m5 to DEV300m50 on WinXP. But it works well in OOo2.4.1
So, reopen
Comment 26 amy2008 2009-06-17 03:56:52 UTC
Set OS from Linux to ALL
Comment 27 amy2008 2009-06-17 04:04:01 UTC
Comment 28 wolframgarten 2009-06-17 08:22:01 UTC
Works in 3.1 but is broken again in DEV300_m50. This is frustrating...
Comment 29 drichard 2009-06-17 14:10:31 UTC
Setting version to m50, and confirming on Linux.  
Comment 30 amy2008 2009-07-06 10:18:14 UTC
meiying to wg,
Doesn't work well in OOo3.1, because if I insert a new slide in this way before
the first slide, find insert the new slide to the end.
Pls check
Comment 31 drichard 2009-10-01 17:22:44 UTC
Still broken in M60 as a regression.  Sending email to
 This would be a show stopper for me deploying to our 700 users.
Comment 32 groucho266 2009-10-02 12:31:45 UTC
The insertion position was already correctly stored but not yet used in this

Fixed by doing that now in SlotManager::InsertSlide().

SVN revision of the change is 276639.
Comment 33 groucho266 2009-10-19 10:41:40 UTC
@wg: Please verify.
Comment 34 wolframgarten 2009-10-20 13:26:05 UTC
Verified in CWS.
Comment 35 drichard 2009-11-02 13:54:11 UTC
Confirmed fixed in _m3, thanks guys!