Issue 943 - Deny messages with attachment on <any list>@openoffice.org
Summary: Deny messages with attachment on <any list>@openoffice.org
Status: RESOLVED FIXED
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Mailing lists (show other issues)
Version: current
Hardware: All All
: P2 Trivial with 4 votes (vote)
Target Milestone: CEE Rubicon
Assignee: Unknown
QA Contact: issues@www
URL:
Keywords:
: 26049 39258 (view as issue list)
Depends on: 6607
Blocks: 2587
  Show dependency tree
 
Reported: 2001-05-23 14:12 UTC by stx123
Modified: 2009-01-23 06:38 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description stx123 2001-05-23 14:12:05 UTC
Recently ~5 messages with attachments containing a virus have been posted.
if no destinction between types of attachments can be made, then disable all
attachments.
Comment 1 stx123 2001-05-23 14:12:58 UTC
.
Comment 2 Unknown 2001-05-23 16:54:14 UTC
+1
Comment 3 Unknown 2001-05-23 19:55:44 UTC
I'm going to go forward enable attachment stripping of all incoming
discuss@openoffice.org mail of the following types of attachments:

.exe
.doc, .xls
.vbs
.bat
.com

Comment 4 Unknown 2001-05-29 05:48:46 UTC
Reassigning to goolie
for ownership 
(to coordinate technical support as required toward resolution). 

Please accept issue (to change status from NEW to ASSIGNED). 

Please provide an update regarding the current status of the resolution of this 
issue.

IMHO, this should be a top priority.




Comment 5 Unknown 2001-07-13 18:46:11 UTC
Goolie's technical tasks now go to David.

-jh-
Comment 6 Unknown 2001-07-16 15:34:43 UTC
i accept this issue and will look into it.  i don't have the history on this
issue so i'm not sure if this will be something that gets fixed in the upcoming
upgrade or not.  i'll look into this and report back.
Comment 7 lsuarezpotts 2001-07-28 18:56:28 UTC
David, please see PCN issue 5181 
(http://projects.collab.net/issues/show_bug.cgi?id=5181) regarding 
disallowing attachments in the discuss list, filed by JH.
-louis

Comment 8 Unknown 2001-07-30 19:07:51 UTC
i'm following up internally to see how best to handle this.  will provide more
information soon...
Comment 9 stx123 2001-11-01 20:36:57 UTC
Louis raised the issue to P1 because of the recent Nimda variant.
Comment 10 lsuarezpotts 2001-11-01 21:22:10 UTC
David,
The pcn issue for this is 6243; I raised it to a p1 and have added kat to the list.
Currently, it's assigned there to CN ops for resolution.
-louis
Comment 11 Unknown 2001-11-08 23:13:49 UTC
changing QA contact from bugs@ to issues@
Comment 12 lsuarezpotts 2001-12-19 20:08:56 UTC
removing david as assignee.
-louis
Comment 13 lsuarezpotts 2002-01-10 21:08:33 UTC
this will be resolved with the upgrade to come in the second quarter of 02
resolving to later
louis
Comment 14 stx123 2002-06-06 14:22:06 UTC
It's Q2 02, for which SC release is functionality planned?
Comment 15 Unknown 2002-06-06 18:03:20 UTC
This functionality is planned for the Truckee release of SC.
Comment 16 stx123 2002-08-15 17:10:20 UTC
Hi, I would like to remind "support" of this issue.
At the moment there is no further action need as it 
is "resolved/later" with a Status Whiteboard entry "PCN (Truckee)".
Comment 17 stx123 2002-08-15 17:11:25 UTC
reopening for reassigning.
Comment 18 stx123 2002-08-15 17:12:09 UTC
reassigning to support
Comment 19 stx123 2002-08-15 17:13:05 UTC
resolved later.
Comment 20 Unknown 2003-07-10 01:23:16 UTC
Reviewing issues marked resolved later and updating whiteboard for
better tracking by CollabNet support.
Thanks,
Kristen
Comment 21 Unknown 2004-10-29 02:09:23 UTC
Mail architecture to be rehauled in a future release. Keywording accordingly 
to reflect the sensitiveness and criticality.  Just so that we can be on the 
same page, can you also provide the business impact due to this issue?
Comment 22 lsuarezpotts 2004-10-30 18:29:03 UTC
ani:
we already limit attachments on many lists; we do not do it by default, but could.  See PCN 11771 for 
the list of mime types banned.  The ultimate point is to have this done via the UI; now it must be done 
tediously via Ops.

Business impact?

Louis
Comment 23 lsuarezpotts 2004-10-30 18:33:57 UTC
*** Issue 26049 has been marked as a duplicate of this issue. ***
Comment 24 lsuarezpotts 2004-10-30 18:33:59 UTC
adding PCN 11771 to whiteboard.
louis
Comment 25 stx123 2004-11-05 20:30:15 UTC
> Business impact?
The impact to our "business" is that we loose mailing list subscribers because
we can't react timely on an insufficent stripping definition. An UI for the list
of mime types to be stripped (or additional stripping criteria) would allow the
configuration via the administrative interface in a reasonable timeframe and
avoind complains from subscribers.
Comment 26 lohmaier 2004-12-19 17:59:52 UTC
*** Issue 39258 has been marked as a duplicate of this issue. ***
Comment 27 grsingleton 2004-12-19 19:03:35 UTC
Change summary to reflect the universal requirement of filtering. 

N-L list are being impacted and I have no doubt that users are affected. This is
a pity as there are good filters that will do this automatically such as
mimedefang (http://www.mimedefang.org/) that work well even with qmail et cetera.
Comment 28 lsuarezpotts 2004-12-21 01:45:07 UTC
as indicated on the mail lists, each list needs to ask me to have filtering. Not all lists want it, you know.

Louis
Comment 29 Unknown 2007-03-07 10:07:08 UTC
Changing the milestone as attachment filtering has been implemented in the
Discussion Services(DS).
Comment 30 Unknown 2007-03-07 17:51:38 UTC
To CRM .
Comment 31 Unknown 2007-03-07 18:05:12 UTC
Updating the whiteboard by adding the case no .
Comment 32 Unknown 2008-02-29 09:38:55 UTC
Hi

This feature is fixed in Rubicon and I have verified the same on a test box
carrying the latest version. I shall close this case for now. Please feel free
to re-open, if the functionality does not satisfy your expectation when site
gets upgraded to Rubicon version of CEE.

Regards,
Vathsan
Support Operations.
Comment 33 Unknown 2009-01-23 06:37:23 UTC
CollabNet Support is currently reviewing the issues under Resolved-Later. If the
issues are fixed currently in any of the present CEE releases, then it will be
marked as Resolved-Fixed.

There might be a few issues which might not be in our future roadmaps which
might be closed as Wontfix unless it does not lie under any custom request.
Comment 34 Unknown 2009-01-23 06:38:08 UTC
Marking as fixed since it is fixed in CEE 5.0