Issue 94336 - Table resized when changing first (not other) column width
Summary: Table resized when changing first (not other) column width
Status: CLOSED DUPLICATE of issue 94340
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: OOO300m5
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: graphicsneedsconfirm
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-25 16:49 UTC by arotenbe
Modified: 2008-09-26 08:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description arotenbe 2008-09-25 16:49:03 UTC
Aaron Rotenberg - Sep 25, 2008

OOO300m5 Impress on Windows XP SP3:

1. Start Impress.
2. Hit "Create" to accept the default blank presentation.
3. Choose Insert|Table from the main menu.
4. Choose "OK" to accept the default of 5 columns and 2 rows.
5. Enlarge or shrink the first column using the right-hand border. Notice that
the size of the table changes to make the column fit.
6. Now try resizing the right border of the second column. Notice that it
resizes by changing the size of the next column while leaving the table's size
the same.
7. Finally, try resizing the right border of the last column. It resizes the
table, which is expected since this border is actually the table's right border.

The Tables in Impress draft specification says, in section 1.7.12, "If the user
changes the width of a column, the width of the next column will be reduced so
that the width of the table stays constant.... If the last column is resized,
the width of the table is resized to fit the new column width." Since the first
column is not the last column, this seems to be a direct, albeit fairly minor,
contradiction of the spec.
Comment 1 wolframgarten 2008-09-26 08:25:37 UTC
Duplicate.

*** This issue has been marked as a duplicate of 94340 ***
Comment 2 wolframgarten 2008-09-26 08:26:09 UTC
Thanks for your help.