Issue 94338 - Table border style fails to change upon selection under certain conditions.
Summary: Table border style fails to change upon selection under certain conditions.
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: OOO300m5
Hardware: PC Windows XP
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-25 17:00 UTC by kdettmann
Modified: 2017-05-20 11:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kdettmann 2008-09-25 17:00:52 UTC
My computer information is: 
     Windows XP SP3
     Intel Dual Core 1.86GHz 
     2 GB RAM
Open Office Version: OOo3.0m5

When border styles are chosen in sequence, the previous style(s) are still retained.

Steps to reproduce this bug:

1. Open a new project in Impress
2. Create a table (I do a 5x5, but table size doesn't matter).
3. Select entire table.
4. When table is selected, there should be either:
    a. A "Table" window that pops up with different properties for the table OR 
    b. A row of properties in the toolbar at the top of the main window.
5. One option of the table properties (specified above) is to pick a border
based on the "Borders" drop down menu.  The button to click for this menu is the
FOURTH button to the RIGHT of the start of the window/table properties toolbar
(It has a light grey square with a small arrow pointing down to the right of it).
6. Click on the "Borders" button, and pick the left-border-only option (the
second choice on the first row that looks like a light grey box with a black
vertical line only on the left side of the box). You should now see a vertical
line on the left side of your table.
7. Now, go back to the "Borders" button, but this time select the
right-border-only option (the third choice on the first row, same light grey box
but this time there's a black vertical line ONLY on the right side). You expect
to see a vertical line only on the right side of your table, but instead you
have one on both the left and right sides of the table.

The problem compounds until you select the no-borders option (the first choice
on the first row that is just a light grey box).
Comment 1 wolframgarten 2008-09-26 08:17:08 UTC
Reproducible. Reassigned.
Comment 2 tito80 2008-11-06 11:40:32 UTC
Also fails when, with table without boders, you want to set all borders in all 
fields:

1. Create a table
2. Select entire table (Table form pops up)
3. In Border buttons select NO-BORDERS button to remove all borders. Ok, the 
table has not any border.
4. Now, select entire table again
5. In Border buttons, select ALL-BORDERS button to set all borders. FAIL!! The 
table only set the external border of selections, and doesn't set all field 
borders.

* The only form to set all fields borders, automatically, is going to Table 
Format, and then go to border tag and set border type.
Comment 3 Marcus 2017-05-20 11:08:15 UTC
Reset assigne to the default "issues@openoffice.apache.org".