Issue 94360 - Applying template style changes overwrites header/footer text
Summary: Applying template style changes overwrites header/footer text
Status: CLOSED WONT_FIX
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.0 RC2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-26 14:19 UTC by lendo
Modified: 2008-10-06 14:18 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test documents. Copy all files in your template folder and open the .odt - header+footer text will be overwritten when applying style changes. (13.49 KB, application/x-compressed)
2008-09-26 14:25 UTC, lendo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lendo 2008-09-26 14:19:37 UTC
I have created a template with customized header and footer (text and styles).
The text of header and footer in documents created from this template will be
adapted for the special purpose (e.g. template header text "Instructions xxx"
and document header text "Instructions Machine type A").

Every time when I change style settings in the template and then when I open the
documents, the header and footer text of the documents will be reset to the text
in the template. But that's not expected when I am reloading only styles (I
thought).

Is this behavior intended?
Should it be possible for templates to overwrite text in documents?

Expected behavior:
Applying template style changes should not overwrite existing text in header/footer.

Maybe this issue is similar to Issue 49754 (loading pragraph styles removes
outline numbering).
Comment 1 lendo 2008-09-26 14:25:50 UTC
Created attachment 56853 [details]
Test documents. Copy all files in your template folder and open the .odt  -  header+footer text will be overwritten when applying style changes.
Comment 2 michael.ruess 2008-10-06 14:17:26 UTC
The content of Header / Footer is stored inside the page style. Thus, when
overwriting a style by a change in a template, the new content will be valid
also in the main document.
Comment 3 michael.ruess 2008-10-06 14:18:49 UTC
Closed.