Issue 9446 - Crash with table of contents and hyperlinks
Crash with table of contents and hyperlinks
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: code
OOo 1.0.1
PC All
: P1 trivial (vote)
: ---
Assigned To: eric.savary
issues@sw
:
: 7815 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-22 13:33 UTC by Unknown
Modified: 2013-08-07 14:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-11-22 13:33:52 UTC
1) Insert...table of contents
2) Insert...frame
3) Type text into the frame
4) Make the text paragrafstyle to "Heading1"
5) Update "index/table" - just to see that it works.
6) Edit index/table
7) Select "Entries"
8) Add a hyperlink "around" then "E".
9) Press OK

Now a "save document" dialog pops up (very unexpected), but whatever you click
(OK/cancel...) OO will crash.

// Jarmo
Comment 1 Oliver Specht 2002-11-25 08:12:58 UTC
Stack: 

SW644MI! SwTOXPara::GetURL(void) + 224 bytes
SW644MI! SwTOXBaseSection::GenerateText(unsigned short,unsigned
short,class SvStringsDtor &) + 1471 bytes
SW644MI! SwTOXBaseSection::Update(class SfxItemSet const *) + 2249 bytes
SW644MI! SwEditShell::UpdateTableOf(class SwTOXBase const &,class
SfxItemSet const *) + 220 bytes
SW644MI! SwWrtShell::UpdateTableOf(class SwTOXBase const &,class
SfxItemSet const *) + 33 bytes
SW644MI! SwTOXMgr::UpdateOrInsertTOX(class SwTOXDescription const
&,class SwTOXBase * *,class SfxItemSet const *) + 1833 bytes
SW644MI! SwMultiTOXTabDialog::Ok(void) + 331 bytes
Comment 2 christof.pintaske 2002-11-25 08:38:13 UTC
Could you shed some light on why you suppose me to handle this issue ? 
Comment 3 Oliver Specht 2002-11-25 10:37:22 UTC
I wanted to assign it to me but I was obviously unable to press the
right keys :-;
Comment 4 jwernerny 2002-11-26 04:30:56 UTC
This sounds very similar to this Issue:

7815 DEFECT P3 Oth sba@openoffice.org UNCO  Crash while updating TOC 
with hyperlinks (document specific)

Have generated 7815, it sounds like a very similar method was used to 
cause it and the results were the same.
Comment 5 Oliver Specht 2002-11-26 06:36:33 UTC
Hi,
7815 sounds pretty similar to me, too. But I was unable to load the
file from the page mentioned in the desciption. 
Comment 6 Oliver Specht 2003-01-21 15:22:56 UTC
Fixed sw/source/core/tox/txmsrt.cxx in cws os4
Comment 7 Oliver Specht 2003-01-21 15:27:18 UTC
*** Issue 7815 has been marked as a duplicate of this issue. ***
Comment 8 Oliver Specht 2003-01-24 15:41:59 UTC
cws os4 is available on so-cwsserv02 for wntmsci9 and unxsols3.pro

Comment 9 michael.ruess 2003-01-27 10:01:31 UTC
MRU->ES: As long as this is your "special section", please test.
Comment 10 eric.savary 2003-01-27 17:48:57 UTC
Fixed
Comment 11 eric.savary 2003-01-27 17:51:25 UTC
Fixed
Comment 12 eric.savary 2003-01-27 17:51:52 UTC
verified
Comment 13 eric.savary 2003-02-21 13:05:37 UTC
Ok Inetgrated in 644m4s2