Issue 94621 - the start of the custom animation path changes location when a ppt file is imported into Impress
Summary: the start of the custom animation path changes location when a ppt file is im...
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: OOO300m9
Hardware: PC Windows 98
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-03 23:16 UTC by les4
Modified: 2013-08-07 15:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
a single slide containing a custom animation that was created using Microsoft PowerPoint (113.50 KB, text/plain)
2008-10-03 23:19 UTC, les4
no flags Details
a single slide containing a custom animation that was imported from a ppt file and saved in odp format (58.69 KB, text/plain)
2008-10-03 23:22 UTC, les4
no flags Details
PPT files used to reproduce and analyse #94621 (97.29 KB, text/plain)
2008-10-05 05:25 UTC, guru_blr
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description les4 2008-10-03 23:16:02 UTC
A slide containing a custom animation was created in Microsoft PowerPoint2002
(10.2623.2625) and saved as slide4.ppt. This was imported into Impress and saved
as slide4.odp. The start point of the custom animation path in slide4.odp is off
the slide.  However, the start point of the custom animation path in slide4.ppt
is on the slide when viewed in PowerPoint. The start point has changed when the
ppt file was imported using open-import.  Both slide4.ppt and slide4.opd are
enclosed.
Comment 1 les4 2008-10-03 23:19:05 UTC
Created attachment 56998 [details]
a single slide containing a custom animation that was created using Microsoft PowerPoint
Comment 2 les4 2008-10-03 23:22:35 UTC
Created attachment 56999 [details]
a single slide containing a custom animation that was imported from a ppt file and saved in odp format
Comment 3 guru_blr 2008-10-05 05:17:55 UTC
I could reproduce the issue.
My environment is XP SP2 with Office 2003  & OOo Version is OOO300m7(Build 9354)

Steps to Replicate:
1. Open a new MS Powerpoint presentation.
2. Insert --> Picture--> select a image on the first slide.
3. Right click on the image, select Custom animation
4. In the 'Custom Animation' side bar, click on 'Add Effect --> Motion path --> 
Draw Custom Path --> Scribble.
5. Scribble the custom path on the slide with start point on the image.
6. Save and close MS PPT
7. Open this PPT in Impress

Voila!! bug reproduced.  
My followup tests confirmed that, the critical condition to this bug is, the 
start point of the custom path should be on the image.  

I will attach the PPTs I created to reproduce this issue.


  
Comment 4 guru_blr 2008-10-05 05:22:25 UTC
I could reproduce the issue.
My environment is XP SP2 with Office 2003  & OOo Version is OOO300m7(Build 9354)

Steps to Replicate:
1. Open a new MS Powerpoint presentation.
2. Insert --> Picture--> select a image on the first slide.
3. Right click on the image, select Custom animation
4. In the 'Custom Animation' side bar, click on 'Add Effect --> Motion path --> 
Draw Custom Path --> Scribble.
5. Scribble the custom path on the slide with start point on the image.
6. Save and close MS PPT
7. Open this PPT in Impress

Voila!! bug reproduced.  
My followup tests confirmed that, the critical condition to this bug is, the 
start point of the custom path should be on the image.  

I will attach the PPTs I created to reproduce this issue.


  
Comment 5 guru_blr 2008-10-05 05:25:30 UTC
Created attachment 57008 [details]
PPT files used to reproduce and analyse #94621
Comment 6 wolframgarten 2008-10-06 08:23:55 UTC
Reproducible. Reassigned.