Issue 94647 - Office freezes when a paragraph in a row breaks over a page break in a combination of protected section, table, frame, and ..
Summary: Office freezes when a paragraph in a row breaks over a page break in a combin...
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 3.0 RC3
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-06 07:36 UTC by cno
Modified: 2017-05-20 11:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description cno 2008-10-06 07:36:58 UTC
Hi, 

I've a document, that freezes the office, when text is added to a table row, so
that a paragraph in the row breaks over a page-break.
By removing protection from the sections, I can prevent the freeze.
However, this is unwanted, because the protection of the section is mandatory.
The document is created from a template.

I've tried all kind of combinations to reproduce the behaviour, starting in a
new document. However, without succes. I can submit those trials, but I can't
submit the original template (or a derived document) to IssueTracker.
I can send it to a developer for debugging.

As said, after removing the protection, Writer does not freeze. But this only if
the protection is removed (either on a new document either in the templete)
before any freeze of the document. When the protection is removed in a document,
recovered after a freeze, the freeze still happens.
Comment 1 michael.ruess 2008-10-06 09:21:27 UTC
Hello Cor,
could you please send the document to mru@openoffice.org? Thanks a lot!
Regards
Michael
Comment 2 cno 2008-10-06 10:00:27 UTC
Hi Michael,
Thanks, done.

Even more bad news: the workaround for removing the protection of the section
only helps, if typing makes the paragraph cross the page when the next row of
the table already is on the next page.
Comment 3 cno 2008-10-06 10:55:06 UTC
Changing the # of columns in the table seems to help.
I send an example for that.
Comment 4 cno 2008-10-15 10:31:05 UTC
Hi Michael,
May I ask if it is possbible to reproduce and - even better - track the problem?
Thanks, Cor
Comment 5 michael.ruess 2008-12-04 09:32:33 UTC
Sorry, it is still not reproducible. We must find out about the differences on
our systems...
Comment 6 cno 2008-12-04 10:28:33 UTC
Working on WinXP (Sp2) it freezes OOo 3.0 and 2.4.1
The printer I select (I tried 3 via File|Printersettings) does not make any
difference.

I also tested on Debian/Gnome (2.14.3).
Indeed, there it does not freeze.

I will try some more variables, and ask some others as well.
Comment 7 michael.ruess 2009-01-28 16:31:32 UTC
Hi Cor,
I am still not able to reproduce this issue. Could you please try to test this
on a different WinXP machine? Maybe deleting the config folder in c:\documents
and settings\[user]\Application data\ on the affected system will help?
Regards
Michael
Comment 8 cno 2009-01-28 23:53:20 UTC
Hello Michael,

Thanks that you are still paying attenion to this!
I did a lot of testing yesterday. 
I had various test-documents, which sometimes freezed the office, and sometimes
didn't.
One of the items of influence: the last paragraph before creating the soft page
break, must only be one line long. And no new page had to be made before. But
also this did not give for a hundred 100% the same result either.

After a while I found a method with which I could reliable freeze ;-) all the
documents.
After many checks, I found out that the freeze would not occur, after setting
the properties of the first (lowered) paragraph back to default.
Today I tried this with the orinial template. I made two changes:
- resetting the first paragraph to default;
- removing the section, that enclosed the first paragraph.
Indeed, the freeze does not happen now.

Two points remain:
- I have to hear the results from my contact.
- Why does it happen on some systems, and not on others ??
(And in fact a third one: I have to design new templates ;-) )

pls stay tuned,
Cor
Comment 9 cno 2009-02-21 22:33:36 UTC
Hello Michael,

Good and bad news ...
The bad: I thought I had found the solution. Nop. Changing the high of the
paragraph at the top only prevented the freeze with thát scenario.
But when using paragraphs with different length, to fill the bottom cell of the
document, the freeze could happen again.
So the good thing: I'm conviced freezing has is related to distance from the
bottom of the cell, or paragraph (or ...?) to the bottom of the page, before the
cell is to break over the pages.
Is that clear and does it give a clue to the developers

Now I redesigned the template, so that no table breaking over the page is
needed. That works (...). So that problem is solved. No only the freezing ;-)
Comment 10 cno 2009-02-21 22:39:46 UTC
Forgot a question mark: 
 Is that clear and does it give a clue to the developers ?

BTW: I've two avi's showing the freeze and non-freeze. If you are interested,
let me know (zipped apr. 1.2 and 1.5 MB)
Comment 11 michael.ruess 2009-02-23 10:05:10 UTC
Hi Cor,
do you have the AutoSpellcheck enabled? AFAIK, there is a problem when having
longer text with enabled AutoSpell...
However, you could send the avi showing the freeze directly... maybe I'll find a
clue there for reproducing...
Comment 12 cno 2009-02-23 10:22:33 UTC
Mi Michael,
There was no autospellcheck enabled. (Also the text was not at all long.)
The avis have been send...

Comment 13 michael.ruess 2009-10-05 14:24:30 UTC
I saw that in this document "use printer metrics" in the compatibility options
is enabled? Which printer driver is active on your system? Maybe with this I can
trigger the loop...
Comment 14 cno 2009-10-05 14:44:31 UTC
The printer is EPSON AL-C1100 Advanced
Comment 15 michael.ruess 2009-10-08 11:22:27 UTC
Hm, also with this printer I do not get the freeze.
Does it still occur with 3.1.1 and 3.2?
Comment 16 cno 2009-10-22 09:21:54 UTC
Hi Michael,
I can reproduce the freeze both in OOO320m2 and 3.1.1
So alas, not solved by miracle.
Comment 17 michael.ruess 2010-05-11 12:18:22 UTC
...and also not reproducible by miracle ;-)
Moving this to "writerneedsconfirm", maybe we can find out reason of loop with
other members together.
Comment 18 eric.savary 2010-05-20 11:50:40 UTC
@Cor: silly question: are you sure it is freezing (the application is not
responding)?
Do you still have the videos you talked about?
Please post a link to them.
Comment 19 eric.savary 2010-05-22 14:47:14 UTC
@Cor: ping!
Comment 20 cno 2010-05-22 17:14:54 UTC
Eric: Pong!
Didn't miss it, but well, you guys in Hamburg are not the only bussy ones :-p

Thanks for your testing, but did I talk about videos? Can't find any.

Since December I am on Ubuntu. Will test it soon with 3.2.1.rcx
And make a video if it freezes here. 
If necessary I'll start the old XP-laptop to test there.

Best would be to get a debug-environment running here. But when :-)

Ciao - Cor
Comment 22 michael.ruess 2011-03-11 14:48:23 UTC
New system - different behavior...

MRU->OD: I am now able to reproduce the problem on my ubuntu-vbox. Let's discuss on Monday how I can help on debugging this...
Maybe it is the same root cause as issue 115990 or issue 102200...
I got it by taking the MEmo_original.ott, created some paragraph breaks so that the table reached the end of page. Then I entered text until it reached the new page -> loop.
Cannot see this on my Win7 or XP machines...
Comment 23 Marcus 2017-05-20 11:17:47 UTC
Reset assigne to the default "issues@openoffice.apache.org".