Issue 94705 - Create a new presentation without background leads to background loos on reload
Summary: Create a new presentation without background leads to background loos on reload
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.3 RC3
Hardware: Unknown All
: P2 Trivial with 1 vote (vote)
Target Milestone: OOo 3.0.1
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
: 91285 92387 96117 96468 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-10-06 17:34 UTC by martin_n
Modified: 2008-12-10 16:16 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description martin_n 2008-10-06 17:34:21 UTC
Steps to reproduce:

1. Use Presentation Wizard
-> Empty presentation -> next
-> select no background -> next
-> create
2. Select "Master Pages" in Tasks and apply a background
3. Save the file and close
3. Open the file again
BUG: The Background is missing. Reselecting it - doesn't schow it.
Workaround: Select an other background -> save -> close ->load -> select the
former background
But after save it gets lost again.

But if you use the template wizard and select a background their it gets saved
correctly.

Thanks.
Comment 1 wolframgarten 2008-10-06 21:03:33 UTC
Ouch. Reproducible. Reassigned.
Comment 2 wolframgarten 2008-10-06 21:12:51 UTC
Broken after beta.
Comment 3 groucho266 2008-10-07 14:22:28 UTC
This is not really broken,  this bug was just not so visible previously.  Master
pages often had shapes that covered the whole background.  In contrast the new
styles (master pages) set the background property to display bitmaps, solid
colors, and so on.

The problem here is the style name that is used to access the style's background
property.  A localized name, concatenated to the style name, is used to set the
property when the master page is assigned.  The plain english name is used to
read the property when the document is saved.
Comment 4 groucho266 2008-10-08 10:24:32 UTC
Please take over.
Comment 5 tomdwright 2008-10-17 21:36:15 UTC
this bug seriously impacts the functionality of impress. it really spoils the
otherwise nice integration of templates.
Comment 6 clippka 2008-10-20 14:25:30 UTC
seems that only the assignment with the task panel is broken. A workaround is to
use menu "format -> slide design"
Comment 7 clippka 2008-10-20 15:55:38 UTC
The bug was in SdStyleSheetPool::CopyLayoutSheets() where sheets are copied but
the help id was not copied with them. Therefore internal style sheets became
user generated style sheets and the localized display name was used as the sheet
name on export.

I searched in sd for the usage of Make() to see if we have other places where
sheets are created without a correct help id. I only found
SdStyleSheetPool::CopySheets() and fixed this also.

I also found FuPresentationLayout::TransferLayoutTemplate() with the same error
but since it is not used anywhere I simply removed the code completely.

Fixed in cws impress163 for OOo 3.0.1
Comment 8 thb 2008-10-27 17:56:36 UTC
*** Issue 92387 has been marked as a duplicate of this issue. ***
Comment 9 clippka 2008-11-03 15:54:28 UTC
verified in cws, back to qa
Comment 10 wolframgarten 2008-11-07 14:42:03 UTC
Verified in CWS.
Comment 11 wolframgarten 2008-11-20 14:45:43 UTC
Tested in m12. Closed.
Comment 12 wolframgarten 2008-11-23 19:33:29 UTC
*** Issue 96468 has been marked as a duplicate of this issue. ***
Comment 13 wolframgarten 2008-11-28 18:31:58 UTC
Verified again.
Comment 14 groucho266 2008-12-01 16:00:48 UTC
*** Issue 96117 has been marked as a duplicate of this issue. ***
Comment 15 groucho266 2008-12-10 16:16:27 UTC
*** Issue 91285 has been marked as a duplicate of this issue. ***