Issue 94973 - please remove the dead entry from the menu ("record macro")
Summary: please remove the dead entry from the menu ("record macro")
Status: CONFIRMED
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOO300m4
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-16 07:38 UTC by macias
Modified: 2017-05-20 11:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description macias 2008-10-16 07:38:29 UTC
When I start recording in writer I get nice dialog with stop button. I can 
save the macro on stop. Etc.

But in math module (called from writer) this does not work. I can start 
recording and I won't even know it anything is been recorded.
Comment 1 michael.ruess 2008-10-16 10:17:50 UTC
MRU->JSK: OO Math does not support macro action at all, right? So it cannot be
recorded...
Comment 2 joerg.skottke 2008-10-22 08:47:14 UTC
That is correct, macro recording is limited to the main applications.
Comment 3 joerg.skottke 2008-10-22 08:49:02 UTC
Close

macias,

if you are really unhappy with this status you can reopen the issue and make it
a RFE (Request for enhancement).
Comment 4 macias 2008-10-22 09:55:07 UTC
I am "unhappy" because it is a defect, but not the way you probably thought.

If there is button "print" I expect I get printout. There is no sane way to 
argue, "oh well, the print does not work by design".

If it was intended/designed to get rid of macro feature from Math then get rid 
of the menu items related to macros. They are there, they are not functioning 
and this is a bug.

So the bug is -- menu is still there, it should be removed.
Comment 5 joerg.skottke 2008-10-23 14:45:02 UTC
Hi macias,

i do not really understand the nature of your report.

Your first post indicated that you are switching from a writer document to math
while recording.

This does not work for two reasons
1) Cross-application recording does not work at all
2) Math is unsupported by the macro recorder

These are both known issues, you might want to have a look at issue 20046 just
to get an idea of what is working and what not. 

My personal suggestion is: Keep your hands off macro recording. It's pretty much
dead. Use the API.
Comment 6 macias 2008-10-23 15:42:34 UTC
The bottom line is -- if you know Z is malfunctioning either fix it or remove 
Z. The menu item says "record macro" so I expect it will record macro (pretty 
common-sense expectation).

My original report has fixing in mind, but since it was closed as wontfix, now 
I opt for removing this item from the menu.

Now there is dead menu item -- this is plain wrong. 
Comment 7 joerg.skottke 2008-10-24 07:03:20 UTC
Hi macias,

i can really understand your frustration about the matter - as you can see in
issue 20046 i've tried to change things in the past - with no success at all.
I've even written half a book containing all the shortcomings of the current
"implementation" and presented it to the management (that was back in the days
when OOo was moving from proprietary to free software).

The problem is that too few people show interest in this functionality because
even if the macro recorder would work, it still produces unreadable code. This
is a drawback of the OOo design. Most people try to generate a code skeleton
with the macro recorder and then want to edit the code to do certain things.
When they look at the code they usually do the "jump out of the window thingy"
and give up.

So most people either do not use the recorder at all or have learned to program
the office using the API. I haven't found anyone in the community willing to
enhance the macro recorder because of the problematic implementation of the
recording functionality. Instead the community opted for the addition of
JavaScript, Python and BeanShell as supported programming languages.

As for the menu entries being there at all, that is for the tick-mark on the
feature list. StarOffice 5.x had a macro recorder. It was removed in StarOffice
6 and re-implemented in StarOffice 7/OpenOffice.org 1.x because there were
people who wanted at least this limited functionality.

Your point is 100% valid and i totally agree. But we're not going to change this
anytime soon. 
Comment 8 joerg.skottke 2008-10-24 08:09:12 UTC
Closing issue again. 
Comment 9 joerg.skottke 2008-10-24 08:09:34 UTC
close
Comment 10 macias 2008-10-24 08:30:39 UTC
There is a dead menu item in the menu. Remove this menu item, please.

I am not wishing for recording capability (thank you for the longer 
explanation) but for REMOVING the dead menu entry.

I am repeating and repeating the issue of removing dead menu entry, and you 
are answering about recording, API, etc. It does not matter what the label of 
the menu item says, the only important thing is it does not work at all. It is 
_dead_. So please remove it.

I am changing the summary to this, because otherwise I guess we will get back 
to the record/API/macro explanation again. It is irrelevant now -- since the 
feature won't be implemented (as you said), there is no point in having such 
menu item.
Comment 11 joerg.skottke 2008-10-24 08:44:44 UTC
But to my understanding the item is disabled? Isn't this the next best thing to
not being there?
Comment 12 macias 2008-10-24 09:04:13 UTC
It is NOT disabled. If it was, I wouldn't start this report.

It is enabled, alive, and ready to be clicked. User clicks, nothing happens.

I opt for rather removing it, not disabling it, since disable suggest, the 
feature is there, it is just a matter of activating it in some way. But 
disable would be also useful (more useful than having it enabled).
Comment 13 joerg.skottke 2008-10-24 11:51:59 UTC
Hi macias,

the problem is that i was absolutely unable to reproduce your problem with the
information given. This was the reason why i resorted to guessing that you do
not like the recording feature. Sorry for that. However, if i do the following:

- Open a new Writer document
- From the Writer document open a Math document
-> The recording option Tools/Macro/Record macro is disabled

All is as expected.

Now i figured that you insert the Math object into the writer document, meaning:

- Open a new Writer document
- From the Writer document select Insert/Object/Formula
-> The recording button is enabled even though the math Object is selected but
the button is without function.

The statement "called from Writer" left multiple options for interpretation.
However, you are right. This is a bug. Confirmed, sending to MBA
Comment 14 macias 2008-10-24 13:24:26 UTC
I am terribly sorry for misleading information -- I only insert formulas to 
the writer, I didn't even once open standalone math module :-) So I assumed it 
was "obvious", my mistake, sorry.
Comment 15 Marcus 2017-05-20 11:13:11 UTC
Reset assigne to the default "issues@openoffice.apache.org".