Issue 95099 - Distorted metafile OLE objects presentation
Summary: Distorted metafile OLE objects presentation
Status: CLOSED DUPLICATE of issue 21668
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.0
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-18 01:02 UTC by raguirre0
Modified: 2008-10-20 16:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
"Good" vector PDF with gradients and bitmaps (39.90 KB, application/pdf)
2008-10-18 01:03 UTC, raguirre0
no flags Details
This is the way the OLE object is displayed in OO 3.0.0 (Draw) (80.52 KB, image/png)
2008-10-18 01:05 UTC, raguirre0
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description raguirre0 2008-10-18 01:02:08 UTC
Initially I thought this was a clipboard issue, as this also happens when doing
copy/paste from external (to OO) applications that support OLE.

So there are 2 ways to reproduce this (tested in Draw, Writer and Calc):
1) Start a brand new metafile object in another application. Best if the object
has gradients or mixed vectors/bitmaps.
2) Copy your object from external application to clipboard (example, from MS
Visio 2007)
3) Paste into OO application: Result, the object is totally distorted.

Another way to reproduce:
1) From Draw, Writer or Calc.
2) Go to Insert/Object/OLE object... menu
3) Insert non OO OLE object that displays as metafile with gradients and
bitmaps. This works even for linked objects from files.

Try with a PDF file, it displays properly in Adobe Acrobat, but when embedded
into Calc is totally distorted. (I'll try to upload an attachment, this is my
first post).
Comment 1 raguirre0 2008-10-18 01:03:25 UTC
Created attachment 57241 [details]
"Good" vector PDF with gradients and bitmaps
Comment 2 raguirre0 2008-10-18 01:05:21 UTC
Created attachment 57242 [details]
This is the way the OLE object is displayed in OO 3.0.0 (Draw)
Comment 3 thorsten.martens 2008-10-20 15:27:50 UTC
TM->MRU: please have a look, thanks in advance.
Comment 4 michael.ruess 2008-10-20 16:34:46 UTC
Already tracked as issue 21668.

*** This issue has been marked as a duplicate of 21668 ***
Comment 5 michael.ruess 2008-10-20 16:41:23 UTC
Closing duplicate.