Issue 95171 - New document opened from WIN EXPLORER without language and without user template styles
Summary: New document opened from WIN EXPLORER without language and without user templ...
Status: CLOSED DUPLICATE of issue 58014
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.0
Hardware: All Windows, all
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@framework
URL:
Keywords: oooqa
: 100801 104268 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-10-20 05:50 UTC by daemonworks
Modified: 2009-08-20 09:30 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
example file (9.12 KB, text/plain)
2008-10-20 18:16 UTC, daemonworks
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description daemonworks 2008-10-20 05:50:21 UTC
I've just installed OOo3. Created a new text file, and start typing. No red 
underlining. Toggled the menu button, still nothing. Hit F7 for a manual 
spellcheck - if finds no errors, even with long strings of random keystrokes.
I'm using Canadian English.

Checked Language Settings/Writing Aids, and hunspell is selected, as are the 
four listed dictionaries (soffice, sun, ignorealllist and standard)

Seriously, spellchecking is a basic function, and it's always a major headache 
to get it to work in OOo...
Comment 1 Rainer Bielefeld 2008-10-20 08:46:20 UTC
I checked with "Ooo 3.0.0 RC4 Multilingual version German UI WIN XP: [OOO300m9
(Build9358)]" and can NOT confirm the reported effect for my texts in German
language.

@daemonworks: 
We need much more information!
What OOo localization did you install?
What language is selected in your document(s) (Format - Character)?
For what languages do you have Dictionaries installed?
Really only WRITER problem, not with CALC?
Please attach a sample document!
Comment 2 daemonworks 2008-10-20 18:16:27 UTC
Created attachment 57319 [details]
example file
Comment 3 Rainer Bielefeld 2008-10-20 18:35:16 UTC
I installed en-ca dict. and tried "nospell.odt"; worked fine.
Looks like an user error, no further information as requested contributed, so I
close this issue.

@daemonworks:
I doubt that you have a working dict. "en-ca" installed (please see.
<http://extensions.services.openoffice.org/download/1335>)
Comment 4 daemonworks 2008-10-20 18:45:20 UTC
More info, as requested:
Have now tested in other modes (calc, etc) - doesn't work anywhere.
Localization = the normal english version.
Dictionaries = the only dictionary extention i've installed myself is English
(Canada). The extention manager says there's also a french and a spanish one.
Language is set to English(Canada) in Format/Character/Western Text Font

If it makes any differance, I had openoffice 2.x installed, and it migrated my 
user info over. The spellcheck was working in 2.x at the time.
Comment 5 daemonworks 2008-10-20 19:12:21 UTC
<sigh> NOT RESOLVED.
the recommended dictionary is the one i've already got installed... and that i 
reinstalled when I noticed spellcheck wasn't working. unsurprisingly, re-
reinstalling it doesn't really do much. 

as for it being a user error: i didn't actually DO anything between 
installation and typing the first time. install -> new document -> start typing 
-> no spellcheck -> double-checked menu toggle & associated settings -> no 
spellcheck -> re-install canadian dict -> no spellcheck -> restarted OOo -> no 
spellcheck... 

where's the error i'm supposed to have made?
Comment 6 Rainer Bielefeld 2008-10-21 07:06:29 UTC
What dictionaries do you see in  the spell check dialogue, that opens after you
pressed 'F7', in the 'Dictionary language pane'? Do the listed languages have a
check?

Same question that opens in menu 'Options -> tools -> Language Settings ->
Writing Aids -> "Hunspell Checker" -> Edit'

Does spell check work if you select other languages in the document?

Did you try to reinstall with deleting your "profile" (Folder "Documents and
Settings -> Anwendungsdaten (I do not know the English word)-> OpenOffice.org"?

Did you install any OOOo3 version before?
Comment 7 daemonworks 2008-10-21 08:26:25 UTC
Ok, it's not actually possible to check anyting in the F7 menu, as it just says 
"spellcheck complete" with an OK button - hitting OK closes the dialog.

When I Edit Hunspell, English(Canada) is not showing up - I'm getting South 
Africa, UK and US, aswell as Spanish and assorted Frenches. So I tried changing 
the document to treat the text as English(South Africa), and the spellchecker 
does work when I do that, so it looks like the bug is probably in the 
dictionary installation system. The dictionary is present in the extention 
manager, but not being seen by hunspell.

I haven't neither deleted my profile and reinstalled nor have I ever installed 
any version of OOo3 other than the final release.
Comment 8 Rainer Bielefeld 2008-11-20 16:07:35 UTC
It seems that no more information can help.
Comment 9 michael.ruess 2009-04-03 08:54:04 UTC
*** Issue 100801 has been marked as a duplicate of this issue. ***
Comment 10 michael.ruess 2009-04-03 08:54:33 UTC
*** Issue 100801 has been marked as a duplicate of this issue. ***
Comment 11 thomas.lange 2009-04-03 13:44:50 UTC
The last time someone with that type of problem showed up in the ML (about a
month ago) it was finally solved (after several other useless tries) by simply
downloading a new dictionary extension for that language. You can check for
available ones here:
http://extensions.services.openoffice.org/dictionary

Download an appropriate one and install it for the single-user.
Since user installed dictionary extensions prevail over system ones there should
be no problem. But you can also remove the system-wide dictionary if you have
the permissions. (Actually it might be necessary to do so if you want to install
a newer version of an existing dictionary.)

Even though doing as above fixed the issue for the user at that time we did not
further explore as to why it does so. Possible reasons could be the content of
the dictionary or the configuration entries made by the extensions.

Please give downloading a new one from the above link a try. If it works drop a
line here as well. QA can then decide if it is worthwhile to try debugging the
case in detail. Before downloading the new extension please write down the name
and exact version of the one you are currently using. It may help us if we want
to try to reproduce the problem. And don't forget to restart the office after
installing the new extension. And be sure to have disabled the quick starter
when you do so.

Adding SBA to cc.
Comment 12 Mechtilde 2009-05-19 20:10:54 UTC
no response -> invalid
Comment 13 Mechtilde 2009-05-19 20:11:21 UTC
.
Comment 14 oceanabby 2009-07-23 18:17:31 UTC
Having similar problems.  Seems to be related to how the document is made.  The
spell checking does not work when a file is created from Windows Explorer:

In Windows Explorer, do a right click -> New -> OpenDocument Text to create an
.odt file.  Open it in OpenOffice.  No spell checking, as described above. 
Interestingly, you can then save this document as MS Word .doc format, open it
in MSWord, and there is still no spell checking.

However, if you start OpenOffice first and create a new document from within
OpenOffice, spell checking works.  It continues to work if you save the file as
MSWord format then open it in MSWord.

I am also using the Canadian English dictionary.

Is some piece of information that spell checking requires missing from files
created by a Windows Explorer right click?
Comment 15 Rainer Bielefeld 2009-07-23 19:18:43 UTC
I checked proceeding as per "comments from oceanabby Thu Jul 23" with "Ooo 3.1.0
WIN XP multilingual version German UI activated  [OOO310m11 (Build 9399)]" and
now I CAN confirm the reported effect.

In WIN Explorer right click -> New -> OpenDocumen Text will create a new
document "Neu OpenDocument Tabellendokument.ods". Creating this document will
not respect User standard new document template and no language will be selected
for Characters. Same Problem with new Calc document.

It would really have saved much time and work if the original report would have
been created more carefully!
Comment 16 Rainer Bielefeld 2009-07-23 19:21:42 UTC
Due to "comments from rainerbielefeld Thu Jul 23"
Comment 17 Rainer Bielefeld 2009-08-17 06:02:48 UTC
*** Issue 104268 has been marked as a duplicate of this issue. ***
Comment 18 Rainer Bielefeld 2009-08-17 06:03:50 UTC
Modified Platform/OS due to Issue 104268
Comment 19 josh_ooo 2009-08-17 11:12:02 UTC
I'have same problem using Vista and OOo3.1. 
Yet strangely, spell checking works for me with your attached "nospell.odt" 
file. 
Comment 20 eric.savary 2009-08-20 02:23:06 UTC
*** Issue 104348 has been marked as a duplicate of this issue. ***
Comment 21 thomas.lange 2009-08-20 08:25:29 UTC
tl->oceanabby: I checked the issue as you described by opening a new document in
the explorer. There are two observations with OOo 3.1 /DEV300_m53:

a) The document languages are borged.
Right away the language statusbar control says: "Mutliple Languages" and if u
open the Format/character dialog you can see that no language at all is set
(applies to all three language boxes). Thus the languages set for this document
are invalid.

b) You can get spellcheck to work again very easily:
After typing some text just 
  1) go to "Tools/Language/For all text" and select the language of your choice
or
  2) press CTRL-A and set the correct language either via Format/Character 
     or the language status bar control.

TL->OS,SBA: Do you know who owns the code that does create documents from within
the explorer window? 
Comment 22 michael.ruess 2009-08-20 09:29:21 UTC
Already tracked as issue 58014.

*** This issue has been marked as a duplicate of 58014 ***
Comment 23 michael.ruess 2009-08-20 09:30:21 UTC
Closing duplicate. AMA is already owner of the "original" task.