Issue 9569 - Fields with 'conditional text' show the condition not the dates after reload
Summary: Fields with 'conditional text' show the condition not the dates after reload
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.1 Beta2
Hardware: PC Windows 98
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
: 14264 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-11-26 23:05 UTC by holgerbruenjes
Modified: 2013-08-07 14:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Muster as PDF (36.30 KB, text/plain)
2003-06-02 22:54 UTC, holgerbruenjes
no flags Details
Muster as sxw (9.11 KB, text/plain)
2003-06-02 22:56 UTC, holgerbruenjes
no flags Details
The document befor saving (25.29 KB, text/plain)
2003-06-14 15:34 UTC, holgerbruenjes
no flags Details
The Document after reload (25.38 KB, text/plain)
2003-06-14 15:35 UTC, holgerbruenjes
no flags Details
The document after reload und printing (24.64 KB, text/plain)
2003-06-14 15:36 UTC, holgerbruenjes
no flags Details
The MySQL dump (8.34 KB, text/plain)
2003-06-14 15:37 UTC, holgerbruenjes
no flags Details
The querry (5.01 KB, text/plain)
2003-06-14 15:38 UTC, holgerbruenjes
no flags Details
The datasource Manager (25.34 KB, text/plain)
2003-06-14 15:39 UTC, holgerbruenjes
no flags Details
the form to input the data in the database (10.66 KB, text/plain)
2003-06-14 15:40 UTC, holgerbruenjes
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description holgerbruenjes 2002-11-26 23:05:32 UTC
I have a document (letter) and put  fields of a Database into as
seriesletterfield also condition fields 'hidden section' and 'condition text'.
This works OK.
When I finished I save it.

Later I open the document and now it is not OK.

All fields with 'condition text' shows the condition not the dates.
 
When I schwitch the printer symbol the dates from the fields 'hidden section'
are emty.

This funktion works OK at SO 5.2 (you can save it and open and print it allways
was OK.

and now in german

Umgebung  WIN98SE  OOo 1.0.1  MySQL  MyODBC

Hier habe ich nun ein Document(Brief) in den ich aus der Datenbank ueber
Serienbrieffelder Daten einfuege, dies laeuft hervorragend.
Auch bei Bedingten Feldern wie Versteckter Absatz und Bedingter Text.

Ich speicher diesen Text mit den eingefuegten Daten.

Spaeter oeffne ich das Document wieder und hier faengt es an zu haken.

Alle Felder in die ich 'Bedingter Text' eingefuegt habe zeigen nur noch die
Bedingung und nicht die Daten.

Wenn ich jetzt auch noch auf Drucken klicke sind auch die Daten aus den Feldern
'Versteckter Absatz' verschwunden.

Und genau dieses verhalten gab es in SO 5.2 nicht.

Man konnte den Text speichern, wieder oeffnen und drucken ohne das ein
Datenverlust auftrat.

Holger
Comment 1 andreschnabel 2003-05-19 20:52:22 UTC
*** Issue 14264 has been marked as a duplicate of this issue. ***
Comment 2 andreschnabel 2003-05-19 20:56:48 UTC
issue was first reportet on OOo 1.0.1 but now also with 1.1beta
->changing Version
Comment 3 holgerbruenjes 2003-05-20 22:15:30 UTC
issue was first reportet on OOo 1.0.1 but now also with 1.1beta2
->changing Version

Comment 4 jzetzsche 2003-05-21 07:19:33 UTC
*** This issue has been confirmed by popular vote. ***
Comment 5 stefan.baltzer 2003-05-28 16:04:56 UTC
SBA->Holger: Please provide a bugdoc and the database. Feel free to
reduce their content as much as possible while still showing the
problem. The smaller the better and the faster the upload ;-)

Please note that problems with conditional text and hiding/showing
sections may as well be two different issues (=> different
developers). We can process only one problem per issue so it's up to
you to write another one in order to get all the problems looked
after. But you may wait for OS comments after he had a look at your
document.

I changed the title to get it closer to the description (Old title:
"to lose dates from database in a document")

SBA->OS: Please check internal #93705 (Conditional Text does not work
without database).
Comment 6 holgerbruenjes 2003-06-02 22:54:21 UTC
Created attachment 6605 [details]
Muster as PDF
Comment 7 holgerbruenjes 2003-06-02 22:56:15 UTC
Created attachment 6606 [details]
Muster as sxw
Comment 8 holgerbruenjes 2003-06-02 23:07:35 UTC
Hi

At the first a send the document whitout the database.
The first document Muster.pdf was printed bevor saving and reload.
The seccond document Muster.sxw was saving and reload. When I look
into the contend the data was there but not of the paper after reload
printing.  
Comment 9 holgerbruenjes 2003-06-14 15:34:34 UTC
Created attachment 6870 [details]
The document befor saving
Comment 10 holgerbruenjes 2003-06-14 15:35:38 UTC
Created attachment 6871 [details]
The Document after reload
Comment 11 holgerbruenjes 2003-06-14 15:36:36 UTC
Created attachment 6872 [details]
The document after reload und printing
Comment 12 holgerbruenjes 2003-06-14 15:37:39 UTC
Created attachment 6873 [details]
The MySQL dump
Comment 13 holgerbruenjes 2003-06-14 15:38:23 UTC
Created attachment 6874 [details]
The querry
Comment 14 holgerbruenjes 2003-06-14 15:39:21 UTC
Created attachment 6875 [details]
The datasource Manager
Comment 15 holgerbruenjes 2003-06-14 15:40:17 UTC
Created attachment 6876 [details]
the form to input the data in the database
Comment 16 hermann 2003-06-29 17:14:19 UTC
Hi *,
I have another bug with conditional text as issue 16127

perhaps it depends on the same code-base as this?
Comment 17 Oliver Specht 2003-07-24 13:16:56 UTC
The problem here was that the result from the last field evaluation
was not saved. This has been changed. 
Changed files: 
sw/source/core/unocore/unofield.cxx unomap.cxx
sw/source/core/fields/docufield.cxx
xmloff/inc/txtfldi.hxx
xmloff/source/text/txtfldi.cxx
offapi/com/sun/star/text/textfield/ConditionalText.idl

Fixed in cws os13
Comment 18 holgerbruenjes 2003-07-27 21:14:35 UTC
Thanks to you
Comment 19 holgerbruenjes 2003-07-30 22:48:19 UTC
Fixed in cws os13, welche Version wird das sein?
Comment 20 Oliver Specht 2003-07-31 07:04:22 UTC
OOo 2.0 development starts on an SRC680 workspace. The integration
date for the child workspace os13 is not yet determined. Maybe it will
be in an SRC680 m2 or m3
Comment 21 andreschnabel 2003-07-31 11:45:28 UTC
Sorry, that I interfere, but we had the same discussion for bugs in
1.0 codeline, that were fixed in 1.1 and never were backported to 1.0.

Users are really concerned about that!

Are we really going to start the same thing for 1.1 <-> 2.0 even
before 1.1 final is out?

Comment 22 Oliver Specht 2003-08-13 12:59:29 UTC
cws os13 can be found on so-cwsserv02
Comment 23 h.ilter 2003-08-15 12:40:19 UTC
Verified with 680m0_8671 (CWS:OS13) = Inserted Auhor as fixed, Saved
as template, Opened a new doc of this template => Initials is displyed.
Comment 24 Oliver Specht 2003-08-18 08:24:55 UTC
OS->HI: You mixed up something. 
Your comment fits to issue 111250 which is fixed in cws os15
Comment 25 Oliver Specht 2003-08-18 08:25:21 UTC
Set to fixed, again.
Comment 26 h.ilter 2003-08-18 11:22:18 UTC
Oh yes, this time I got it and it looks good.
The conditional field keep the view.
Verified with 680m_8671 (cws:os13) = ok
Comment 27 h.ilter 2004-03-22 15:50:15 UTC
Verified with integrated src680m31s1_8763 = ok
Comment 28 holgerbruenjes 2004-06-20 20:26:51 UTC
I have installt the 680m41, and the problem ist fixed for the monitor.

When i printing, the dates are lost at the same before.
Comment 29 holgerbruenjes 2004-06-20 20:30:16 UTC
I vergot OS Linux SuSE 8.1 
Comment 30 holgerbruenjes 2004-06-21 09:24:15 UTC
New Issue 30502