Issue 95698 - crash on switching a particular document from web layout to print layout
Summary: crash on switching a particular document from web layout to print layout
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 3.0
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-31 13:19 UTC by caolanm
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
example .odt (41.42 KB, application/vnd.oasis.opendocument.text)
2008-10-31 13:19 UTC, caolanm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description caolanm 2008-10-31 13:19:02 UTC
The attached document crashes for me when switching from print layout to web layout
Comment 1 caolanm 2008-10-31 13:19:43 UTC
Created attachment 57609 [details]
example .odt
Comment 2 michael.ruess 2008-11-03 15:25:27 UTC
MRU->OD: crashes reproducible. Does not seem to deal with notes2, because
OO2.4.x also crashes. Please have a look, there are a lot of graphics in the
document.
Comment 3 michael.ruess 2008-11-03 15:42:15 UTC
The report ID is rpuquuc. Crash happens in SwTxtNode::GetScalingOfSelectedText,
but there's many times SwTxtNode::fillSoftPageBreakList before it; maybe
something for AMA or FME?
Comment 4 Oliver-Rainer Wittmann 2008-11-12 11:52:35 UTC
First investigation reveals that the layout structure is broken:
- A follow text frame has no master text frame any more.
- A text frame inside a table at some point is no longer inside a table

Should be fixed for OOo 3.1
Comment 5 Oliver-Rainer Wittmann 2008-11-13 15:36:43 UTC
First investigation reveals that two different stack traces are reproducible:
- Switch to "Web layout" after the formatting of complete document is ready
--> null pointer access due to inconsistent layout - follow text frame without
master
- Switch to "Web layout" as soon as it is possible
--> null pointer access due to inconsistent layout - text frame with "IsInTab"
flag set, but no upper table frame found.

accepted - planning a fix for OOo 3.1
Comment 6 Oliver-Rainer Wittmann 2008-12-22 14:30:29 UTC
defect cause:
A table, which is inside a section, which is inside a table, which is inside a
table, which is inside a table - yes, the attached text document has this layout
- stays inside the section, but leaves the nested table structure during the
layout process. Thus, a certain follow text frame loses its master text frame.

[Layout of the text document:
The text document contains table 2, which has one cell containing table 3, which
has one cell containing table 4, which is very large (30 pages) and contains
several sections, which each contain a small table.]
Comment 7 Oliver-Rainer Wittmann 2008-12-22 14:48:35 UTC
fixed in cws sw31bf03 - changed file:
/sw/source/core/layout/sectfrm.cxx, rev. 265753
Comment 8 Oliver-Rainer Wittmann 2009-01-05 13:19:28 UTC
OD->MRU: Checked in internal installation set of cws sw31bf03 - please verify.
Comment 9 michael.ruess 2009-01-07 11:10:44 UTC
Verified in sw31bf03.
Comment 10 Oliver-Rainer Wittmann 2009-01-16 12:27:29 UTC
Review of the already committed fix with AMA and FME reveals that it needs to be
adjusted.

I decided together with MRU that the adjustment of the fix will be made in cws
sw31bf04.
Comment 11 Oliver-Rainer Wittmann 2009-01-16 14:05:04 UTC
revised fix in cws sw31bf04 - changed file:
/sw/source/core/layout/sectfrm.cxx, rev. 266419
Comment 12 Oliver-Rainer Wittmann 2009-01-21 14:56:36 UTC
OD->MRU: Checked revised fix in internal installation set of cws sw31bf04 -
please verify.
Comment 13 michael.ruess 2009-01-26 13:47:35 UTC
Verified in CWS sw31bf04.
Comment 14 michael.ruess 2009-02-02 14:51:03 UTC
Checked in DEV300m41.