Issue 95710 - Date object pasted from another workbook sheet with different date base changes value
Summary: Date object pasted from another workbook sheet with different date base chang...
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: PC (x86_64) Linux, all
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
: 106789 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-10-31 16:45 UTC by bhlevca
Modified: 2017-05-20 09:54 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
original XSL file (2.59 MB, application/vnd.ms-excel)
2008-10-31 18:46 UTC, bhlevca
no flags Details
File with pasted date column (398.50 KB, application/vnd.ms-excel)
2008-10-31 18:47 UTC, bhlevca
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bhlevca 2008-10-31 16:45:43 UTC
If you copy a column of date objects from a worksheet and paste it in another
workbook sheet column the date showing up is shifted by about 4 years. 

The file was in XLS format and I could test it in Excel 2007. In Excel pasting
data objects to another workbook (file) works fine, i.e. does not change the
date value.
Comment 1 Rainer Bielefeld 2008-10-31 18:08:43 UTC
I checked with "Ooo 3.0.0 RC3 Multilingual version German UI WIN XP: [OOO300m8
(Build9357)]" and can NOT confirm the reported effect.

@bhlevca 
Please attach a sample document!
Comment 2 bhlevca 2008-10-31 18:46:00 UTC
Created attachment 57624 [details]
original XSL file
Comment 3 bhlevca 2008-10-31 18:47:32 UTC
Created attachment 57625 [details]
File with pasted date column
Comment 4 Rainer Bielefeld 2008-10-31 19:06:55 UTC
Currently I see this issue as INVALID, reason for the pseudo problem are
different bases for calendar date in both documents.

@bhlevca, pls. see:
1. Open "Inner_Harbour_July.xls"
2. Menu 'Tools -> options -> OOo Calc -> Calculate - Date'
   You will see base Date 01/01/1904

11. Open "DateProof.xls"
12. Menu 'Tools -> options -> OOo Calc -> Calculate - Date'
    You will see base Date 12/30/1899 (default)
    That causes the different date view.

You have to use the same data base for all documents to avoid that problem.
Comment 5 bhlevca 2008-10-31 19:33:11 UTC
Thanks for the information.

It is good that is not a calculation problem, however, I think that it should be
a common/standard starting calculation date for all the sheets. 
I understand that this issue occurred  probably because the file was imported
form Excel. 

Although I pasted with All fields enabled, the start calculation date I guess is
not copied with it. 

It would be nice as an enhancement to have the starting calculation date taken
from the original in a case of copy/paste Date object.

I will reopen it as an enhancement, because I think it is a real problem and it
will save time for a lot of people, and besides, OO has to become better than Excel.
Comment 6 Edwin Sharp 2013-11-23 19:51:44 UTC
Copy column B of attachment 57624 [details] and paste into new spreadsheet - date is wrong.

AOO410m1(Build:9750)  -  Rev. 1539999
2013-11-09_04:08:11 - Rev. 1540252
Debian
Comment 7 Rainer Bielefeld 2014-03-03 18:35:36 UTC
Correct Version: has been observed first with OOo 3.0
Comment 8 Rainer Bielefeld 2014-03-03 21:27:42 UTC
As already told in Comment 4 both documents have different date bases, and Date base 01.01.1904 of Inner_Harbour_July-1.xls is different from normally for new .ods  used 30.12.1899. So here nothing is unexpected or a bug.
Comment 10 Andre 2014-03-04 08:06:12 UTC
Can anybody explain why it is not an error that the base dates are not automatically adapted?  Do we not have all the necessary information at hand to a) detect the problem and b) solve it?
Comment 11 Rainer Bielefeld 2014-03-04 09:17:09 UTC
(In reply to Andre from comment #10)
> Can anybody explain why it is not an error that the base dates are not ...

We have some comments at 
<https://issues.apache.org/ooo/show_bug.cgi?id=106789>
<https://issues.apache.org/ooo/show_bug.cgi?id=28223>

Of course the "table:null-date" parameter (ODF 1.2 Part 1: OpenDocument Schema 9.4.2 <table:null-date>) is known and can be used "somehow", but I see lots of snares, I think that would need a well prepared new feature request.
Comment 12 Andre 2014-03-04 11:51:24 UTC
Comments 2 and 3 of bug 106789 are revealing and utterly unhelpful: a developers view of UI.  We do conversions in other cases (resolution for sizes, color spaces, etc).  Why not dates?
Comment 13 Rainer Bielefeld 2014-03-05 06:19:26 UTC
*** Issue 106789 has been marked as a duplicate of this issue. ***