Issue 95744 - Macro recording problems with arrow-keys in formula
Summary: Macro recording problems with arrow-keys in formula
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 2.4.1
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2008-11-01 16:41 UTC by davidhoria
Modified: 2013-01-29 21:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description davidhoria 2008-11-01 16:41:02 UTC
1. Record macro
2. Type 1 + Enter
3. Type 2 + Enter
(You are now in cell A3)
4. Type =, Type Up
5. Type +, Type Up Type Up + Enter
(=A2+A1) in A3
6. Stop record macro
When you playback macro it doesn't do the same (error).
Comment 1 Stefan Weigel 2008-11-02 19:57:55 UTC
Can confirm with OOo 3.0 (OOO300m9) and OOo 2.4.1.

Problem seems to be, that using the arrow-keys for entering a cell reference is
erroneously recorded as using the arrow-keys before starting to enter the formula.

davidhoria, please indicate your OOo version.
Comment 2 davidhoria 2008-11-06 12:54:52 UTC
I tried all OO versions including 3 beta and the problem is the same.
Comment 3 tomwb 2008-11-07 01:42:05 UTC
The recorded macro loses the reference to the formula target cell, placing the
result in the position of the last cell movement by use of the arrow key.  I
tried several different macros that started the use of the arrow keys in
different positions.  It always places the formula in the last position selected
by an arrow key.

Comment 4 tomwb 2008-11-07 02:02:58 UTC

It occurred to me, just after my previous post, to try this out in Excel 2003. 
I recorded the macro verbatum.  Saved the file, opened it in OOo 3.0 then saved
it as an ods file.  The macro runs correctly.  Go figure!