Issue 95811 - Image in background prevents selecting text which is above it with mouse
Summary: Image in background prevents selecting text which is above it with mouse
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 3.0
Hardware: All Windows XP
: P3 Trivial with 13 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
: 108205 115051 117215 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-11-04 05:46 UTC by natess44
Modified: 2017-05-20 11:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample document, see "comments from rainerbielefeld Tue Nov 4 " (22.33 KB, application/vnd.oasis.opendocument.text)
2008-11-04 10:31 UTC, Rainer Bielefeld
no flags Details
an example of the picture problem (548.89 KB, application/vnd.oasis.opendocument.text)
2008-11-04 15:28 UTC, natess44
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description natess44 2008-11-04 05:46:36 UTC
This Problem is in both OOo 2.2 and 3.0 and may be in more versions.  The
problem occurs when you paste or add an image and make it a background.  If
there is text above the image you cannot select the text.  The image is selected
every time.  Apparently if you add the image in format/page/background this
solves the problem but doesn't allow for easy editing of the text document. 
Perhaps adding a lock feature to the image would fix this problem or making it
harder to select the image than the text.

It is a rather basic problem so a test file I don't think is needed but email me
if you need an example.
Comment 1 Rainer Bielefeld 2008-11-04 06:12:01 UTC
@natess44:
please attach a sample document (no Idea how you placed the image as background
for the text).
Comment 2 michael.ruess 2008-11-04 09:56:20 UTC
MRU->AMA: this has partly been fixed in issue 28595, but it is still not
possible to select text which floats over a graphic "in background".
Comment 3 Rainer Bielefeld 2008-11-04 10:30:13 UTC
I checked with "Ooo 3.0.0 RC3 Multilingual version German UI WIN XP: [OOO300m8
(Build9357)]" and can confirm some of the reported effects, pls. see attached
sample document "mytest.odt":

Let's take word "ligula" covered by the Packman-image:

Search and replace "ligula" by "xx" will work.

Mouseclick into the image works.

All further tests start with caret between "g" and "u":

Highlight with <cntrl>+arrow key works, caret will move and higlight.
All edit operations I tried for highlighted characters did work, as long as I
use toolbars or menu.

Highlight with mousepointer-drag does not work correctly. Press left mouse
button and move mouse pointer left / right: As long as you move the mouse
pointer (with pushed left mouse button) only within the picture, nothing
happens, caret remains at it place. If you leave picture area highlighting will
start.

All context menu operations for text will not work, because picture will be
selected.

I agree, that' a defect, not an enhancement
Comment 4 Rainer Bielefeld 2008-11-04 10:31:59 UTC
Created attachment 57695 [details]
Sample document, see "comments from rainerbielefeld Tue Nov 4 "
Comment 5 natess44 2008-11-04 15:28:00 UTC
Created attachment 57700 [details]
an example of the picture problem
Comment 6 natess44 2008-11-04 15:34:59 UTC
I just remembered and tested it with my sample document.. if you try selecting
the text with the mouse and select text on one side of the image(not over the
image) and drag as if you were selecting text the text that is directly over the
image will not get selected until you get to the other side of the image.  I
found a work around to this but I had to use the arrow keys and the shift key to
do it.
Comment 7 natess44 2008-11-04 15:36:01 UTC
I just remembered and tested it with my sample document.. if you try selecting
the text with the mouse and select text on one side of the image(not over the
image) and drag as if you were selecting text the text that is directly over the
image will not get selected until you get to the other side of the image.  I
found a work around to this but I had to use the arrow keys and the shift key to
do it.
Comment 8 eric.savary 2009-08-20 19:21:10 UTC
Reassigning to MBA in order to be dispatched.
Comment 9 Mathias_Bauer 2009-11-11 13:50:29 UTC
Oliver, please take over
Comment 10 michael.ruess 2010-01-11 08:50:46 UTC
*** Issue 108205 has been marked as a duplicate of this issue. ***
Comment 11 mbelow 2010-01-16 13:47:36 UTC
This makes working with a letterhead (in EPS format) very difficult. Sometimes
it is possible to return to text editing using the ESC key, sometimes it is not:
e.g. if you insert a table on top of a whole-page background image and press F2
to make a calculation, the image comes to the front and you can't return to the
table by pressing ESC. It is possible to get around this by adding the draw
toolbar and clicking onto the white arrow twice.

(Version 3.1.1 on Debian testing, AMD64)
Comment 12 Oliver-Rainer Wittmann 2010-01-21 14:32:56 UTC
After MRU helped me to understand the problem here are the results:
- editing text which is above a graphic which is in background works since fix
for issue 28595.
- selecting text which is above a graphic which is in background with the mouse
does not work.

Thus, adjusting the summary accordingly.
Comment 13 Oliver-Rainer Wittmann 2010-01-21 16:06:22 UTC
defect cause:
The code which searches for the new selection end point also considers Writer
graphics, Writer embedded objects and Writer text frames. Thus, an invalid
selection is detected and suppressed.

possible solution:
Depending on selection start point Writer graphics/embedded objects/text frames
have to be considered or not, when search for the new selection end point.
Comment 14 eric.savary 2010-10-13 14:30:49 UTC
*** Issue 115051 has been marked as a duplicate of this issue. ***
Comment 15 michael.ruess 2011-03-07 09:35:01 UTC
*** Issue 117215 has been marked as a duplicate of this issue. ***
Comment 16 Marcus 2017-05-20 11:17:59 UTC
Reset assigne to the default "issues@openoffice.apache.org".