Issue 95828 - cws create fails to create an EIS entry
Summary: cws create fails to create an EIS entry
Status: CLOSED FIXED
Alias: None
Product: Build Tools
Classification: Code
Component: code (show other issues)
Version: DEV300m35
Hardware: Unknown Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: jens-heiner.rechtien
QA Contact: issues@tools
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-04 13:11 UTC by kyoshida
Modified: 2009-04-06 16:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kyoshida 2008-11-04 13:11:33 UTC
I've having a hard time creating a new svn-based cws.

First, I've tried the following command (in DEV300-m29)

  cws create DEV300 charthiddencells

The script successfully created a new svn branch with that name, but the script
failed to connect to EIS database & *no* EIS entry was created (I didn't get the
exact output, sorry).  I manually created a new EIS entry for this cws via web
interface, but there is no way to manually set the milestone and the 'new' status.

Next, I've downloaded DEV300-m35 and tried to create a new cws in the m35
environment once again.  This time I specified the milestone explicitly.

  cws create -m 35 DEV300 koheitest00

This too failed to connect to EIS database, but this time it *did* create a new
EIS entry.  But it just failed to set the svn flag.

Here is the output of my second trial:

---
$ cws create -m m35 DEV300 koheitest00
cws -- version: 1.1.2.14
... check cws path:
'svn+ssh://svn@svn.services.openoffice.org/ooo/cws/koheitest00', OK
... create branch:
'svn+ssh://svn@svn.services.openoffice.org/ooo/cws/koheitest00', committed
revision 263319
Warning: web service unavailable. Trying backup server.
ERROR: Connection to EIS database failed.
 at /home/kyoshida/ooo/charthiddencells/solenv/bin/modules/Cws.pm line 1758
cws: ERROR: Failed to set subversion flag on child workspace 'koheitest00'.
Contact EIS administrator!


FAILURE: cws aborted.
---

I have several CWSes that are migrated from CVS, and running 'cws query current'
returns correct information.  So my connection to EIS should be fine.

Any ideas?
Comment 1 kyoshida 2008-11-04 13:15:34 UTC
Here is my .cwsrc (without the real CWS_PASSWORD)

[CWS_CONFIG]
CWS_DB_SERVER_1=https://eis.services.openoffice.org/soap/servlet/rpcrouter
CVS_ID=kohei
CVS_PASSWORD=*********
CVS_SERVER_ROOT=:pserver:kohei@localhost:/cvs
SVN_SERVER=svn+ssh://svn@svn.services.openoffice.org/ooo
Comment 2 jens-heiner.rechtien 2008-11-13 10:49:43 UTC
Kohei,

these failures look like temporary outtages of the EIS server to me. Can you
still not create CWSs with "cws create"?

Heiner
Comment 3 kyoshida 2008-11-13 13:03:16 UTC
@hr: as I said in my first description, I was able to run 'cws query current'
which returned with the right information.  So it was not because of EIS outage.
Comment 4 kyoshida 2008-11-13 13:38:19 UTC
Also, I can create a new cws with a new EIS entry.  It just won't set the "this
is svn" flag to the EIS entry.  So, the entry says "no" under "Is this svn" flag.
Comment 5 jens-heiner.rechtien 2009-04-06 16:54:22 UTC
@kohei: I've just checked it out. New CWSs do set the subversion flag correctly.
I think this fixes this issue, if you still have problems please reopen this issue.
Comment 6 jens-heiner.rechtien 2009-04-06 16:54:51 UTC
Close issue.