Issue 95894 - Saving slow on small document with tables
Summary: Saving slow on small document with tables
Status: CLOSED DUPLICATE of issue 17565
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOO300m9
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2008-11-06 01:56 UTC by pbouf
Modified: 2009-01-15 06:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Example file for issue 95894 (12.78 KB, application/vnd.oasis.opendocument.text)
2008-11-06 02:06 UTC, pbouf
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description pbouf 2008-11-06 01:56:12 UTC
Saving a document is slower than it ought to be. This is admittedly subjective,
but as someone coming to OO with MS Word experience I can say that on the same
class machine and same size document, saving is noticeably "slow" in OO. I
acknowledge that this may be in part due to an unfair comparison to Word's
background save. But I'm a compulsive Ctrl+S'er, a habit I don't want to give up
for OO.

OS: Ubuntu 8.04, hardware: Thinkpad T40p, 1.6 GHz, 2 GB ram. Files saved to
local HD, not network.

Thanks for a great product, aside from some relatively small things like this I
am very satisfied using OO exclusively for my personal office suite needs.
Comment 1 pbouf 2008-11-06 02:06:47 UTC
Created attachment 57728 [details]
Example file for issue 95894
Comment 2 pbouf 2008-11-06 02:09:25 UTC
Not sure if it's related but the attached document contains a table. When I save
it on my machine it takes approx. 3 seconds; for a 13K file that seems a bit
high to me. One thing I do notice is if I remove all the text and just save the
document with an empty table, it's significantly faster.
Comment 3 michael.ruess 2008-11-20 13:40:32 UTC
Performance problem regarding saving and loading documents containing tables is
tracked as issue 17565.

*** This issue has been marked as a duplicate of 17565 ***
Comment 4 michael.ruess 2008-11-20 13:41:23 UTC
Closing duplicate.