Issue 95947 - Drag&Drop of image from certain browser impossible
Summary: Drag&Drop of image from certain browser impossible
Status: CLOSED DUPLICATE of issue 15381
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL: http://photos.nafai.org/image/29637
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2008-11-07 10:23 UTC by david
Modified: 2008-11-19 01:16 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description david 2008-11-07 10:23:51 UTC
Dragging an image from a webpage into Open Office Writer merely creates a link
to the image, whereas one would expect the image to be copied to the
document. 

1) Open e.g. this page - http://photos.nafai.org/image/29637

2) Drag the image into an empty OO Writer document

3) Save the document. The file is only about 60k, and clearly does not
contain the image. If the image is removed from the website, the
document can no longer be used.
Comment 1 eric.savary 2008-11-07 16:17:35 UTC
Cannot reproduce. The image is copied unlinked.
What is your system? Your browser?
Comment 2 david 2008-11-07 16:36:18 UTC
It's Win XP pro SP2 - Firefox v3.0
Comment 3 michael.ruess 2008-11-07 20:42:24 UTC
I also tried with OO3 and FireFox 3 on WinXP. The graphic was correctly inserted
linked into the document. It just needed about 5 seconds to display its content.
Could you please check your settings in Tools.Options.Internet.Proxy?
Comment 4 thorasmund 2008-11-08 02:17:42 UTC
If the image is dragged from Internet Explorer into OO3 the file is inserted
unlinked (the way you would expect). If the image is dragged from FF3 into OO3
only a link to the image is created. The actual image is not copied to the
document. The action should be the same regardless of whether you use Explorer
og FireFox.
Comment 5 eric.savary 2008-11-19 01:15:28 UTC
@filkin: Please be accurate when reporting issue. Your summary said "Importing
image from webpage impossible" which is wrong. The image is imported as linked
frame. If you want to embed the image, go to "Edit - Links" and then break the link.

An option for this is not yet implemented and is addressed with issue 15381.

@thorasmund: you said "the way you would expect". One may exactly expect the
contrary: have a linked image and not a copy (to have smaller documents or get
the last update on an image whose content is changing but not its link...)

But this is already discussed in issue 15381, i Think.


Last: Well, on my system (Windows Vista) this is the contrary:
- IE 7, I only get a text hyperlink
- FF3: a linked graphic

Honestly, it used to work from all browsers (incl. FF2) but after a started and
restarted IE/FF3/FF2 alternatively, this is my last result: works fine with FF3,
doesn't work with IE.

So this difference may be investigated in an other issue.

By now, this one is a duplicate.

*** This issue has been marked as a duplicate of 15381 ***
Comment 6 eric.savary 2008-11-19 01:16:04 UTC
Closed