Issue 96031 - Aqua: Calc Shortcuts "Command + Cursor" no longer work (jump to block start/end)
Summary: Aqua: Calc Shortcuts "Command + Cursor" no longer work (jump to block start/end)
Alias: None
Product: porting
Classification: Code
Component: MacOSX (show other issues)
Version: OOO300m9
Hardware: Mac Mac OS X, all
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 3.1.1
Assignee: oc
QA Contact: issues@porting
Keywords: aqua, oooqa, regression
: 94857 (view as issue list)
Depends on:
Blocks: 101565
  Show dependency tree
Reported: 2008-11-10 08:44 UTC by russe13
Modified: 2010-06-07 11:49 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description russe13 2008-11-10 08:44:04 UTC
I use the german language only version of OpenOffice. There are the standard keyboard shortcuts to jump 
to the end of a block with Command + Arrow Key.
Command + Arrow Up is working fine.
Command + Arrow Down is working fine.
Command + Arrow Left does not work at all.
Command + Arrow Right does not work at all.

I also reset the preferences for the shortcuts but jumping to the left or right end of a block does still not 
Comment 1 recpiper 2008-12-09 16:44:49 UTC
Same issue in english language OpenOffice 3.0.0 on Mac OS X 10.5.5

Command + Arrow [up/down/left/right] is assigned to move to
[top/bottom/left/right] of block in keyboard shortcuts.

Command + Arrow Up moves to top of block
Command + Arrow Down moves to bottom of block
Command + Arrow Left does nothing
Command + Arrow Right does nothing

Command + Control + Arrow Left moves to left of block
Command + Control + Arrow Right moves to right of block
Comment 2 lohmaier 2009-04-29 17:47:13 UTC
confirming with OOo 3.0.1.

A regression of issue 80485?

Navigating to the top/bottom of a block works as expected, but navigating to the
left/right doesn't. (<command>+<arrow>)

Selecting to the beginning/end of a block works in all directions like expected

Tools|Configure → Keyboard shows the correct shortcuts, but they don't have any
effect as described. Assigning a different shortcut, like <command>+8 works, so
the functionality itself is not affected, just the shortcut-handling.
Comment 3 russe13 2009-05-07 20:27:57 UTC
Things getting worse in OOo 3.1

(<command>+<arrow>) does not work anymore for top/bottom which did in 3.0.1

Tools|Configure → Keyboard still shows the correct shortcuts for top/bottom and left/right.
Comment 4 2009-05-08 13:05:34 UTC
None of the Command+Cursor and Command+Shift+Cursor work anymore in OOo31 on the aqua port.
Comment 5 philipp.lohmann 2009-05-08 14:51:43 UTC
The <modifier> Arrow shortcuts produce native key behavior now (see e.g. in
writer). Unfortunately that killed them in calc. We need either new shortcuts
for calc on the mac or change the behaviour so it works.

Set tentative 3.1.1 target.
Comment 6 herrdeh 2009-05-13 16:01:55 UTC
I manually set up a number of shortcuts in calc, which worked fine in 3.0.1, I
edited ¯/Library/Application\

All of them are now (3.1) out of order, e.g. "FillDown", FillRight", "Bold" etc.

Going back to 3.01 )-:


Comment 7 lohmaier 2009-06-03 21:23:47 UTC
*** Issue 94857 has been marked as a duplicate of this issue. ***
Comment 8 philipp.lohmann 2009-06-04 19:16:46 UTC
fixed in CWS ooo311gsl03; if one of the "special" system keys (like "select to
end of line") is not understood, we can try the original key event. This makes
the <modifier>-Arrow and similar combinations work again in calc while keeping
the new "system key" functionality in the other applications.

This means of course that the "system key" wins over the configuration if both
are understood; cleaning the configuration from duplicates to system keys is
however a matter for CWS macshortcuts02.
Comment 9 philipp.lohmann 2009-06-08 18:23:22 UTC
please verify in CWS ooo311gsl03
Comment 10 h.ilter 2009-06-15 10:55:51 UTC
In favor for OC, verified with cws ooo311gsl03 = OK 
Command + Arrow Right jumps to column AMJ (1024)
Command + Arrow Left jumps back to A (1)
Command + Arrow Down jumps to row 65536
Command + Arrow Up jumps back to 1
Comment 11 herrdeh 2009-11-13 09:36:52 UTC
I'm trying 320m4 Build:9450 PPC german on Mac OS X 10.4.11.

Never had such a quick and responsive OOO - wow, very good work.

But the keyboard issue is still present: Neither can I change keyboard shortcuts
with the special tool ("Extras" menu), nor do my manually edited shortcuts under
make any effects.

What a pity!
Comment 12 russe13 2010-02-16 11:10:15 UTC
Seems to be fixed in version 3.2.0 now.
Shortcuts working as expected:

Command + Arrow Up moves to top of block
Command + Arrow Down moves to bottom of block
Command + Arrow Left moves to left of block
Command + Arrow Right moves to right of block

Should this ticked be closed now?
Comment 13 thorsten.ziehm 2010-06-07 11:49:08 UTC
This issue is closed automatically. It is in state 'verified/fixed' since 2
releases (OOo 3.1.1 and OOo 3.2). The policy [1] indicates that such older
issues should be closed.

If this issue still occur in a current build (OOo 3.2.1 or >DEV300m80) please
reopen the issue and set the target accordingly.

[1] :