Issue 96123 - combining characters (diacritics) not displaying properly
Summary: combining characters (diacritics) not displaying properly
Status: CLOSED DUPLICATE of issue 78749
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: Unknown Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: hdu@apache.org
QA Contact: issues@gsl
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2008-11-12 02:06 UTC by tjslager
Modified: 2010-03-18 17:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
pdf - graphite-enabled vs DejaVu (31.25 KB, application/pdf)
2010-03-18 17:40 UTC, lohmaier
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tjslager 2008-11-12 02:06:51 UTC
OO does a poor job of rendering unicode combined characters. I figured it was a
Linux problem, until I noticed that the little Ubuntu accessory, Tomboy Notes,
renders combined characters perfectly.

Tone mark over upper case character: Tomboy puts the tone mark above the
character; in OO the tone mark steps on the character.

Combined nasalization and tone mark: Tomboy puts the tone mark above the
nasalization tilde; OO renders them on top of each other.

Combined nasalization and tone mark over upper case character: Tomboy, perfect;
OO, let's not even go there.

Example: O + U0303 should display each character of the combined character, so
that it looks like U00d6. Add a high tone mark such as U0301, and the tone mark
should appear above the tilde. As it is they are all mashed together and the
diacritics are not distinguishable. Printing gives the same results.

It's mostly readable in OO, but some tone marks cannot be distinguished, and it
is not of a quality to be printed and distributed. If my friends in Liberia want
a Bassa document written in OO, they have to save it as an MS file on media,
find a Windows computer, open the file in Word (or Excel) and then print it. 

Not ideal. (But at least it's a work-around they can probably manage for now.)
Comment 1 ooo 2008-11-12 09:31:42 UTC
Hi Herbert, probably your construction site.
Comment 2 nmailhot 2008-11-12 10:09:43 UTC
Probably just an effect of OO.o's current poor support of OpenType features
(both in TTF and OTF fonts)

See issue #16032 or issue #78749

Comment 3 lohmaier 2010-03-18 17:38:44 UTC
Depends on the font - and since OOo now has graphite support, using a graphite 
enabled font should display with no problem.

(apart of issue 43080)

Anyway, duplicate.

*** This issue has been marked as a duplicate of 78749 ***
Comment 4 lohmaier 2010-03-18 17:40:30 UTC
Created attachment 68416 [details]
pdf  - graphite-enabled vs DejaVu
Comment 5 lohmaier 2010-03-18 17:41:14 UTC
closing