Issue 96221 - Crash when opening a huge draw-document with linked grafics
Summary: Crash when opening a huge draw-document with linked grafics
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Draw
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0
Hardware: All Windows XP
: P2 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: groucho266
QA Contact: issues@graphics
URL:
Keywords: crash, needmoreinfo, regression
Depends on:
Blocks:
 
Reported: 2008-11-14 19:50 UTC by jr
Modified: 2008-12-06 20:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jr 2008-11-14 19:50:13 UTC
Error-Report-ID: rspcvuc

Concerning document was created with OOo 2.4, Win XP. When opening it in 3.0,
OOo crashes just after loading and scrolling in the page pane.

Unfortunately the document is confidential and because of the grafics very large
(25 MB). I can send the document directly to someone, who wants to have a look,
or I can upload it (protected with a password).
Comment 1 jr 2008-11-14 19:50:52 UTC
adding keywords
Comment 2 wolframgarten 2008-11-14 21:16:25 UTC
You can send it to me directly ( wolfram.gartensun.com ). did you receive an
error report id already? Thanks in advance.
Comment 3 jr 2008-11-15 11:41:46 UTC
Thanks a lot, I will send you the files directly. I mentioned the error report
ID already in my first post: rspcvuc, another one is: rjunvuc
Comment 4 wolframgarten 2008-11-15 16:13:26 UTC
Ok, thanks for the doc. Sorry I have overseen the error report in the first
line. Reproducible. Reassigned.
Comment 5 groucho266 2008-11-27 12:49:34 UTC
Can reproduce the crash with an OOO300 m9 but not with a DEV300 m34.  Seems to
have been fixed as side effect (probably by the huge changes in the drawing layer.)
Comment 6 groucho266 2008-11-27 12:50:26 UTC
Closing issue because the crash is not reproducible anymore.
Comment 7 Rainer Bielefeld 2008-11-27 16:17:25 UTC
Confirm crashes with "Ooo 3.0.0 (DE) Multilingual version German UI WIN XP:
[OOO300m9 (Build9358)]".

I see that with all my documents having many (20 or more) slides, big linked
Images (used as a kind of "background" on a locked layer. Some times I have to
try several times to open the document, and OOo gets into a recovery loop.
Not only document open crashes DRAW, also working with the documents is more or
less impossible, because OOo crashes all few minutes. Currently I do not see any
system, OOo crashes when it wants.
Unfortunately I can not create a crash report, OOo crashes without creating a
report. 
Comment 8 groucho266 2008-11-27 16:59:40 UTC
@rainerbielefeld: Please read my comments above carefully.  Yes, I can reproduce
the crash on a OOO300 m9.  However, I can *not* reproduce it on a DEV300 m34. It
may have been fixed as a result of the recent drawing layer re-implementation.

If you can reproduce this crash on a version DEV300 m30 or above then I will try
to fix it.  Otherwise I will close this issue again.
Comment 9 Rainer Bielefeld 2008-11-27 19:53:27 UTC
I am testing with DEV300 m36, but pls. see  Issue 96669!
Comment 10 Rainer Bielefeld 2008-11-28 16:16:27 UTC
Now I am pretty sure that this problem is solved with "OOO300 m9", and I'm
afraid we have to accept TM 3.1, although this bug makes OOo3 unusable for
everyone who has to work with bigger affected DRAW documents.
Comment 11 Mechtilde 2008-12-06 20:28:12 UTC
worksforme -> closed