Issue 96557 - SUMIF with a string with jolly character criteria doesn't work
Summary: SUMIF with a string with jolly character criteria doesn't work
Status: CLOSED DUPLICATE of issue 32344
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO300m9
Hardware: PC Windows Vista
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2008-11-24 22:08 UTC by trigone
Modified: 2008-12-06 20:19 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Excel 2003 sheet showing syntax difference from Calc (7.50 KB, application/vnd.ms-excel)
2008-11-28 14:36 UTC, tomwb
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description trigone 2008-11-24 22:08:48 UTC
I have a simple spreadsheet that sums the values in column B if the 
corresponding rows in column A contain a string like "andrew*". This works fine
in Excel but fails to work in OO.

ie.:
formula is: =SUMIF(A1:A5;"=price*";B1:B5)

 col A           col B
andrew brown       1
mattew green       5
andrew red         3
robert white       2
andrew black       5

The result could be 9, but it is 0.
Comment 1 Rainer Bielefeld 2008-11-28 13:22:08 UTC
I checked with "Ooo 3.0.0 (DE) Multilingual version German UI WIN XP: [OOO300m9
(Build9358)]" and can NOT confirm the reported effect. Vista-specific?

@trigone:
Great idea to type the example instead of attaching a sample document ;-)
Can you please attach a document demonstrating your problem?

Comment 2 tomwb 2008-11-28 14:36:30 UTC
Created attachment 58364 [details]
Excel 2003 sheet showing syntax difference from Calc
Comment 3 tomwb 2008-11-28 14:45:00 UTC
Attached an Excel 2003 win xp sp2 workbook that shows the syntax differences
between Excel and Calc. Calc needs a period (stop) added to the formula along
with regualar expressions enabled.  It appears that Calc does not translate the
Excel syntax to Calc syntax.  This was using OOO300m9 (Build:9358) and Dev300m35
(Build:9367) Calc versions.

TomW
Comment 4 Rainer Bielefeld 2008-11-28 16:47:06 UTC
@trigone:
'Tools -> Options -> Calculate', checked "enable regular expressions in
formulas", everything will work as expected for the sample document. But OOo
regular expression ".*" is something different from EXCEL's "*". for support of
those simple wildcards we have Issue 32344

May be also information in "Wontfix" Issue 91873 might be interesting for you.

May be you want to vote for Issue 32344

*** This issue has been marked as a duplicate of 32344 ***
Comment 5 Rainer Bielefeld 2008-11-28 16:47:24 UTC
.
Comment 6 Mechtilde 2008-12-06 20:19:24 UTC
duplicate -> closed