Issue 96735 - Removing On-Line update component causes OOo crashes
Summary: Removing On-Line update component causes OOo crashes
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: DEV300m36
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: Olaf Felka
QA Contact: issues@framework
URL:
Keywords: crash, regression
: 96979 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-11-30 16:42 UTC by newuser4
Modified: 2009-02-13 11:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description newuser4 2008-11-30 16:42:32 UTC
Avoiding installation of on-line update component during setup or removing it 
from a working installation causes OOo to crash when selecting menu 
Tools->Options.

To reproduce the issue install OOo DEV300m36 and skip installation of on-line 
update component.
As just as you select menu Tools-> Options soffice.bin will always look for 
file \Program Files\OOo-Dev 3\program\basis\updchk.uno.dll regardless if it 
has been installed or not and it will crash if the file is not present.

This issue can be reproduced in DEV300m35 and DEV300m36, it is not present in 
DEV300m12.
Comment 1 Olaf Felka 2008-12-07 13:23:55 UTC
*** Issue 96979 has been marked as a duplicate of this issue. ***
Comment 2 mhatheoo 2008-12-07 19:49:32 UTC
seeing  issue 96979 (related to M37) I guess you may want to set status to new
and raise the priority.
Thanks

Martin
Comment 3 Olaf Felka 2008-12-08 21:23:23 UTC
@ dv: Please have a look.
Deselecting online update and going to tools options crashes the office.
Comment 4 dirk.voelzke 2008-12-11 07:05:57 UTC
Fixed in cws dv05 in svx\source\dialog\treeopt.cxx
Comment 5 dirk.voelzke 2008-12-15 07:50:33 UTC
Please verify.
Comment 6 Olaf Felka 2008-12-16 11:14:36 UTC
OF: Is ok in cws dv05
Comment 7 Olaf Felka 2009-02-13 11:30:41 UTC
OF: Is ok in OOO310_m1