Issue 96825 - in base query format is not memorized
Summary: in base query format is not memorized
Status: REOPENED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: recent-trunk
Hardware: PC Windows 7
: P3 Trivial with 1 vote (vote)
Target Milestone: OOo 3.2
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 101708 (view as issue list)
Depends on:
Blocks:
 
Reported: 2008-12-03 08:31 UTC by maurice_starck
Modified: 2013-01-29 21:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
small data base to check the loss of querie's formatting (115.26 KB, application/vnd.sun.xml.base)
2008-12-11 10:58 UTC, maurice_starck
no flags Details
test file with formatted queries (6.19 KB, application/vnd.sun.xml.base)
2010-09-04 12:12 UTC, maurice_starck
no flags Details
query_format_test.odb with queries' format lost (6.16 KB, application/vnd.sun.xml.base)
2010-09-04 12:13 UTC, maurice_starck
no flags Details
Screen print of query now unformatted (41.87 KB, application/vnd.oasis.opendocument.text)
2010-09-07 15:02 UTC, hem10000
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description maurice_starck 2008-12-03 08:31:56 UTC
Display a query with a numerical field on the right of the list ("document").
Run the query (double clic) in a new window and change the format of the columns
(width, alignment, user defined numeric format: # ###,00;[RED]-# ###,00). Close
that window, save the modified file and exit OOo.
When you reopen the file everything is reset to the default (changes are lost):
   display to "none"
   alignment to "left", number format to "standard" ...
I noticed this behavior occasionally in version 2.4 (after a recovery) but in
version 3 it seems permanent.
Comment 1 Frank Schönheit 2008-12-08 13:24:40 UTC
Could you attach a sample-DB (.odb, with embedded HSQLDB) which shows this
behavior? I know it happens in some situations, but was not able to nail it down
so far to a reproducible scenario. If you'd have a .odb which easily allows
reproducing it, that'd be great.
Comment 2 maurice_starck 2008-12-11 10:56:36 UTC
I create an attachment test.odb
Of course all formatting is default.
Comment 3 maurice_starck 2008-12-11 10:58:07 UTC
Created attachment 58708 [details]
small data base to check the loss of querie's formatting
Comment 4 Frank Schönheit 2008-12-17 13:29:26 UTC
fs->oj: with the attached database, I could reproduce that the alignment of the
column "CC_Nouméa" in query "chrono_banks" is lost when you
- change the alignment to "Right"
- close the query
- save the DB doc
- close the DB doc
- re-open the DB doc
- open the query, again

fs->maurice_starck: Which query/column is it where the number formatting and
column width is lost? I tried a few, but except the missing alignment, all other
attributes were preserved for me.
Comment 5 maurice_starck 2008-12-18 00:11:56 UTC
I made the test again several times and lost everything.

Then I added a few records in query "chrono_banks" and suddenly I got the same
result as you: only the display status and the alignments are lost.
Very strange! I'm now unable to reproduce what I noticed during dozens of tests!
I also tested a recovery after shutting down the computer: same result.

I'll wait and see... and report if it happens again.
Thanks for your interest.


Comment 6 maurice_starck 2008-12-23 13:04:47 UTC
Again I lost all number formats in the last four queries after a recovery!
Comment 7 maurice_starck 2009-01-04 03:55:38 UTC
Every two days or so there occur a recovery of the file, and each time ALL the
query formats are completely lost.
Comment 8 Frank Schönheit 2009-01-08 14:09:03 UTC
Okay, if you have a complete loss together with some crash/auto-recovery, then
please cross-check with issue 93071 - it describes the problem that in 3.0, all
changes done to a file *before* a crash/recovery are lost from the original file
*after* recovery. Sounds a little bit like this is what hit you. If not, please
elaborate (step-by-step).
Comment 9 maurice_starck 2009-01-09 12:59:06 UTC
The changes I lose are not always related to recovery; they have sometimes be
done several days before and the file has been open/saved after that. I have no
problem with data, only with format in queries.
Comment 10 Frank Schönheit 2009-01-09 13:12:02 UTC
Hmm, but this description unfortunately does not allow to reproduce the problem,
and thus not to fix it :(

So, this issue here continues to describe the problem with the lost alignment of
chrono_banks.CC_Nouméa.
Comment 11 maurice_starck 2009-01-10 00:26:59 UTC
Yes... I can only describe what I notice!
If I work with the file, after a few days ALL the formats (not only the
alignment, also the numerical format and the column's width) disappear from ALL
the queries. I cannot find anything related with the event but it occurs every
few days.
I reformat the columns and everything but the alignment is saved... but
disappear again after a few days.
I'll make more tests on test.obd and report if I find something more precise.
Comment 12 ocke.janssen 2009-01-29 13:30:32 UTC
Fixed in cws dba32a
Comment 13 ocke.janssen 2009-02-26 08:59:21 UTC
Please verify. Thanks.
Repro:
- open bug doc
- open query chrono_banks
- change the alignment of column "CC_Nouméa" to "Right"
- close the query
- save the DB doc
- close the DB doc
- re-open the DB doc
- open the query, again

=> the alignment is gone.
Comment 14 Frank Schönheit 2009-02-26 12:32:57 UTC
targeting to 3.2, since the fix is part of a CWS aiming for this release
Comment 15 maurice_starck 2009-02-27 04:39:02 UTC
In the test file (not used for a about a week)
The alignment is systematically lost in all queries
When I opened it the numeric formats were gone in the two first queries
(chrono_banks & solde); I formated the columns again and now they are still
there after several open/close.

In my file (from which the test file was extracted) I notice the same behavior:
- systematic lost of all alignments
- systematic lost of the status of the right panel (document -> none)
- periodic lost of formats in some queries (not always the same!)

Please also note that each time I open a file "save" is proposed on exit, even
if no changes have been made.
Comment 16 Frank Schönheit 2009-02-27 09:19:39 UTC
This bug here, as far as we could reproduce it, is fixed in CWS dba32a, which is
not yet integrated into the main trunk. You might want to give the CWS snapshot
at ftp://qa-upload.services.openoffice.org/dba32a/ a try, and see if the problem
persists there.
Comment 17 marc.neumann 2009-04-15 14:27:49 UTC
verified in CWS dba32a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32a
Comment 18 ocke.janssen 2009-05-27 07:42:13 UTC
*** Issue 101708 has been marked as a duplicate of this issue. ***
Comment 19 maurice_starck 2010-09-02 07:49:10 UTC
I changed my laptop and the new one runs Windows 7.
I installed OpenOffice.org 3.2.1  OOO320m18 (Build:9502).
On January 29 2009 oj announced "Fixed in cws dba32a"... but the bug is still
there. Should it be fixed in version 3.2.1 or will the fix appear in a next version?
Comment 20 Frank Schönheit 2010-09-02 08:27:38 UTC
see above - we never could reproduce the complete bug you described, but only a
problem with a column alignment. This is the part which got fixed, and yes, it
should be fixed in 3.2.1. Other parts might still be there, but since we never
saw them ... :(
Comment 21 maurice_starck 2010-09-03 09:06:38 UTC
If I refer my daily experience nothing has been fixed in version 3.2.1.
I still loose regularly ALL formats in my queries, not only the alignments but
also the numeric formats.
I can't understand that you are not able to reproduce it. I use the French
version but I believe that it's not related to the loss of query format.
I'll build an other small application to test the bug on a new file. Are you
interested to get it... if the problem persists?
Comment 22 Frank Schönheit 2010-09-03 10:32:36 UTC
definitely "yes"
Comment 23 maurice_starck 2010-09-03 12:15:55 UTC
Just an idea before doing a new test: could the problem come from a corrupted
profile?
Comment 24 Frank Schönheit 2010-09-03 12:25:35 UTC
unlikely, IMO
Comment 25 maurice_starck 2010-09-04 12:10:00 UTC
I created a small test file (query_format_test.obd) with one table and five
queries. I saved it, close it, re-opened it, added some entries, save it
again... without problem. But after several tests (open, add/modify entries,
save, close) the format of the last three queries disappeared!
I'll create two new attachments:
query_format_test.obd with formatted queries (I hope that the format will be saved!)
and query_format_lost.obd with the lost format.
You may also notice that the choice made for the bottom right part of the window
("document") isn't memorized (always reset to "none"). Since I use the French
version the "..." might be slightly different.
Comment 26 maurice_starck 2010-09-04 12:12:03 UTC
Created attachment 71554 [details]
test file with formatted queries
Comment 27 maurice_starck 2010-09-04 12:13:21 UTC
Created attachment 71555 [details]
query_format_test.odb with queries' format lost
Comment 28 hem10000 2010-09-07 08:08:12 UTC
I have just loaded 3.2.1 and will check over the next few days whether I still
have the problem.
Comment 29 hem10000 2010-09-07 15:02:03 UTC
Created attachment 71602 [details]
Screen print of query now unformatted
Comment 30 hem10000 2010-09-07 15:13:15 UTC
Well, it hasn't taken long!

I downloaded Maurice's test file with formatted queries this morning and checked
that all the queries were formatted correctly when run on my machine. They were.
 But now they're not - see screen print in previous comment.

I have also lost the formatting in queries from my own databases.  I formatted
these yesterday after loading 3.2.1 and shut down overnight.  They were OK this
morning but, having shut down and restarted again, they are unformatted again. 



Comment 31 Frank Schönheit 2010-09-08 07:01:33 UTC
thanks for providing the new documents. I'm buried deep within other work at the
moment, so unless somebody from the QA teams looks into this, the issue has to
wait a few more days before I can spend time on it ...
Comment 32 Frank Schönheit 2010-09-14 06:30:42 UTC
Phh. Okay, I see the .odb with e.g. query_x having a certain number format on
the last two columns, and I see the .odb where this format doesn't exist anymore.

However, I do not know how to get from the one to the other, though I spent some
time playing with the query. That is, query_format_lost.odb is already broken,
there's no way to "recover" the lost format from it. Consequently, we need to
know *how it happens* that a format is lost - I do not mean "how it happens
technically", but what steps to do in the UI to provoke such a loss.

Any chance you nail this down, so you can give a more specific description than
"But after several tests (open, add/modify entries, save, close)"?
(http://qa.openoffice.org/issue_handling/basic_rules.html#reproducibility)
Comment 33 maurice_starck 2010-10-11 09:11:57 UTC
I played several times with the queries... without lost of format.
I just noticed that the choice made for the display at the bottom right isn't
memorized (another related bug?). I don't have that problem in my other DBs.

Two days ago I reformatted the 20 queries in an other DB; today everything was
gone! Yesterday I just modified a few fields and closed it.

After one more test with query_format_test.odb I just lost the format of the
four last queries after changing the alignment (left -> center) of the field
"date" in the first query and saving/closing.
I reopened, reformatted the 4 queries and save/closed. Then I reopened and made
the reverse change (center -> left) and saved/closed. When I reopened again the
format of the 2 last queries were gone. I reformatted them, saved/closed. Third
change of the alignment of the date, saved/closed. After reopening everything
was correct! and now I can't reproduce the preceding behavior... No luck!

I'm very sorry to not be able to be more precise. I can't find exactly what
causes the lost; I just notice it. I'll continue to test and let you know if I
find something which can be reproduced.

I also tested "save & close" and found no difference when I
 save then close (with the red cross or using "quit" in the file menu or Ctrl+Q)
 or close and save after the warning windows poped up.
Comment 34 maurice_starck 2010-11-25 10:24:06 UTC
Since a few days I lose again all or mostly queries' formats, even if I just do
a check and close the DB.
You should notice that I usually do my updates in the queries, but that might
not be relevant because the lost occurs even if no updates have been made.

Strangely the problem appears far most often in my bank DB (size 260 Kb) than in
the test DB (only 6.4 Kb).
The only other difference that I have found between the two DBs is the
memorization of the option for the content of the bottom right window: document
is memorized in the big DB but always reverts to none in the test DB (changing
it and then Ctrl-Q don't produces the alert "the file has been modified" in the
test DB).

I'm really tired to redo the same work again, again and again...
Comment 35 maurice_starck 2011-02-14 08:30:15 UTC
After an upgrade to version 3.3 things are worse, but easy to reproduce.
Now none query format is memorized; even the save button remains grayed after
changes in a format, thus everything is lost as soon as the query window is closed.
I formatted the fields in the table; these formats are displayed in the queries,
but all other fields (for example sums) remain unformatted.