Issue 97048 - Japanese help is displayed using Chinese fonts on Max OS X 10.4.11
Summary: Japanese help is displayed using Chinese fonts on Max OS X 10.4.11
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: DEV300m37
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: aqua, CJK
Depends on: 97167
Blocks:
  Show dependency tree
 
Reported: 2008-12-09 05:00 UTC by yuko
Modified: 2017-05-20 10:47 UTC (History)
6 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot (207.64 KB, image/png)
2008-12-09 05:01 UTC, yuko
no flags Details
Adding "Osaka" as default font used for MacOSX help (1.13 KB, patch)
2008-12-12 00:45 UTC, maho.nakata
no flags Details | Diff
default.css for Japanese. (1.99 KB, text/plain)
2008-12-12 00:49 UTC, maho.nakata
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description yuko 2008-12-09 05:00:31 UTC
Installed OOo_Dev_DEV300_m37_MacOSXPowerPC_install_ja.dmg on Max OS X 10.4.11.

When running OOo and opening any help topic, Japanese help contents seem to 
be displayed using Chinese fonts.

This problem does not occur in Max OS X 10.5.5.

Please see the attached screenshot.
Comment 1 yuko 2008-12-09 05:01:16 UTC
Created attachment 58639 [details]
screenshot
Comment 2 Olaf Felka 2008-12-09 07:30:14 UTC
reassigned
Comment 3 maho.nakata 2008-12-09 07:38:50 UTC
ekato:

could you please review this issue and make some comments?

Best regards,
Comment 4 kla 2008-12-09 14:37:48 UTC
@Ufi: its your part or coni?
Comment 5 Uwe Fischer 2008-12-09 17:00:11 UTC
certainly not an issue of English help contents.
Comment 6 rafaella.braconi 2008-12-10 10:20:22 UTC
Ivo, can you please look into this? Not sure if this something for you....
Comment 7 ivo.hinkelmann 2008-12-10 12:35:06 UTC
hmmm ... this seems to be mac os x related. Maybe some of the mac gurus can help
here?

Eric ? ... Pavel ?
Comment 8 eric.bachard 2008-12-11 12:13:02 UTC
Reassigning
Comment 9 maho.nakata 2008-12-12 00:45:28 UTC
Created attachment 58730 [details]
Adding "Osaka" as default font used for MacOSX help
Comment 10 maho.nakata 2008-12-12 00:47:48 UTC
yuko and all:

This is due to:
helpcontent2/source/auxiliary/ja/default.css
does not have valid font names for MacOSX.
Adding "Osaka" font as default.

I attached the patch and it works.
 
Comment 11 maho.nakata 2008-12-12 00:49:14 UTC
Created attachment 58732 [details]
default.css for Japanese.
Comment 12 maho.nakata 2008-12-12 00:50:02 UTC
yuko-san:

could you please download "default.css" and

% sudo cp default.css
/Applications/OpenOffice.org.app/Contents/basis-link/help/ja/default.css
?

this should work for you.
Comment 13 yuko 2008-12-12 01:39:40 UTC
Hi maho-san,

The attached default.css works fine.
The help contents were displayed correctly using Japanese fonts.
Comment 14 maho.nakata 2008-12-12 03:39:53 UTC
Hi hdu!

do you have cws handy? if possible could you please integrate
this patch to your cws?

thanks!
Comment 15 hdu@apache.org 2008-12-12 13:25:17 UTC
> if possible could you please integrate this patch to your cws?

Will do (CWS vcl98)
Comment 16 hdu@apache.org 2008-12-12 13:25:59 UTC
.
Comment 17 hdu@apache.org 2008-12-17 13:16:55 UTC
@fpe: please consider Nakato Maho's improvement for helpcontent2/source/auxiliary/ja/default.css

The first patch (patch-i97048: adding Osaka as a default font for japanese) was already done by issue 97167, 
which got into CWS vcl98.
Comment 18 Martin Hollmichel 2009-04-17 15:06:32 UTC
@frank, this issue sounds quite severe and easy to fix, any comments ?
Comment 19 thorsten.ziehm 2009-05-18 15:18:58 UTC
What is about this issue? OOo 3.1 is released, so the target of this issue has
to be adopted. I change it to OOo 3.x until a release is planned for this issue.
If it is fixed now, please close the issue.
Comment 20 Rob Weir 2013-03-11 15:01:54 UTC
I'm adding this comment to all open issues with Issue Type == PATCH.  We have 220 such issues, many of them quite old.  I apologize for that.  

We need your help in prioritizing which patches should be integrated into our next release, Apache OpenOffice 4.0.

If you have submitted a patch and think it is applicable for AOO 4.0, please respond with a comment to let us know.

On the other hand, if the patch is no longer relevant, please let us know that as well.

If you have any general questions or want to discuss this further, please send a note to our dev mailing list:  dev@openoffice.apache.org

Thanks!

-Rob
Comment 21 Marcus 2017-05-20 10:47:54 UTC
Reset assigne to the default "issues@openoffice.apache.org".