Issue 97207 - Formulas Damaged after Crash: Only displayed as "Objects"
Summary: Formulas Damaged after Crash: Only displayed as "Objects"
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOO300m9
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-12 15:23 UTC by padyx
Modified: 2009-04-03 16:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot of Damaged file (329.26 KB, image/jpeg)
2008-12-12 15:24 UTC, padyx
no flags Details
The damaged file (Writer document) (252.41 KB, application/vnd.oasis.opendocument.text)
2008-12-12 15:26 UTC, padyx
no flags Details
The intact file (Writer Document; backup) (501.96 KB, application/vnd.oasis.opendocument.text)
2008-12-12 15:28 UTC, padyx
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description padyx 2008-12-12 15:23:35 UTC
Hello!

I have discovered a problem with my Install of OO.org 3 for Mac:

When I work on a document in Writer with a lot of included formulas, the app
sometimes seems to save my document incorrectly or crash unpredictably.

The result is that the file then is "locked" (I can open it read-only or as a
copy) and that all the formulas are gone - in their place, there are big giant
"Objects" (see screenshots and attached files).

OpenOffice neither removes the lock nor manages to restore the file
automatically - manually removing the hidden lock file using the Terminal does
the trick - however, the formulas are still gone.
Interestingly they are still formatted as "Formulas" in the Formatstyle window.

I havent't found a similar issue here yet.

What I've already checked to fix the issue:

- Reinstallation (twice) including deletion of all preference files, Application
Support folders ...
- Checking the disk with DiskUtility of Mac OS X (no errors)
- Looking in Error Messages in Console (There are none)

I will attach the corrupt version (ZF-IT-corrupt.odt file) and the most recent
backup (ZF-IT-intact.odt) of the file as well as screenshots.

Should anyone require more information, I will try my best :-)

Thank you in advance.
Comment 1 padyx 2008-12-12 15:24:50 UTC
Created attachment 58775 [details]
Screenshot of Damaged file
Comment 2 padyx 2008-12-12 15:26:31 UTC
Created attachment 58776 [details]
The damaged file (Writer document)
Comment 3 padyx 2008-12-12 15:28:48 UTC
Created attachment 58777 [details]
The intact file (Writer Document; backup)
Comment 4 michael.ruess 2009-02-04 16:42:44 UTC
I was not able to reproduce the problem here, after generating a crash, the
objects still looked fine after recovery.
Maybe the problem is in the way the crash was generated on your system. Do you
remember the steps or the work you did before the crash occurred?
Does this still happen after upgrading to OOo 3.0.1?
Comment 5 padyx 2009-02-04 18:34:51 UTC
Hi mru.
Thanks for your answer and interest in the issue.

As far as I can remember, I had been writing many formulas and text. I did save
in between and have (re-)formatted the document as well.

Interestingly the issue only occured 2-3 times after I reported the issue - and
not anymore since (about Christmas holidays...)
I have not yet upgraded to 3.0.1

Can you open the attached damaged file? Does it look wrong to you as well or normal?

What I find very interesting is that all formulas are affected and not only the
one edited when the crash occured. (I don't know how the file format saves the
formulas...)
Comment 6 eric.savary 2009-04-03 16:29:34 UTC
According to reporter's comments: to reproducible anymore.
Maybe one of the appearance of the "temp problem on MAC"...? (issue 100230)
Comment 7 eric.savary 2009-04-03 16:29:44 UTC
closed