Issue 97261 - Delete content of one cell in table and cut the cell, OOo crashes
Summary: Delete content of one cell in table and cut the cell, OOo crashes
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: DEV300m37
Hardware: PC All
: P2 Trivial (vote)
Target Milestone: OOo 3.1
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
: 96929 97736 (view as issue list)
Depends on:
Blocks: 84405
  Show dependency tree
 
Reported: 2008-12-15 08:02 UTC by amy2008
Modified: 2009-02-17 08:34 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2008-12-15 08:02:37 UTC
Can reproduce it in Drawing and Impress with DEV300m37 on WinXP and Ubuntu

How to reproduce it
1 Create a new Drawing or Impress document
2 Insert a table into the new document, then select one of the cells in the
  inserted table, the following two methods can make the same result:
  a. Hit Delete key, then Edit - copy or Edit - Paste
  b. Click Cut button on the standard bar, then click Paste or copy on the
standard bar

Result
OOo crashed

Expectation
OOo works well

Li Meiying
Comment 1 amy2008 2008-12-15 08:04:00 UTC
CC to Pj and RedFlagzhulihua
Comment 2 Olaf Felka 2008-12-15 09:19:43 UTC
@ wg: Please have a look.
Comment 3 wolframgarten 2008-12-15 10:15:20 UTC
Reproducible. Reassigned. Component adapted.
Comment 4 clippka 2009-01-14 10:46:48 UTC
*** Issue 96929 has been marked as a duplicate of this issue. ***
Comment 5 clippka 2009-01-14 10:53:09 UTC
*** Issue 97736 has been marked as a duplicate of this issue. ***
Comment 6 clippka 2009-01-14 12:21:52 UTC
fixed in cws impress166 for OOo 3.1
Comment 7 clippka 2009-01-21 13:45:27 UTC
verified in cws, back to qa
Comment 8 wolframgarten 2009-01-26 15:09:57 UTC
Verified in CWS.
Comment 9 wolframgarten 2009-02-17 08:34:38 UTC
Tested in OOO310_m1. Closed.