Issue 97262 - Undo-Redo don't work well after splitting cells
Summary: Undo-Redo don't work well after splitting cells
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: DEV300m37
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 84405
  Show dependency tree
 
Reported: 2008-12-15 08:18 UTC by amy2008
Modified: 2017-05-20 10:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2008-12-15 08:18:44 UTC
Can reproduce it in Drawing and Impress with Dev300m37 on WinXP and Ubuntu.

How to reproduce it 
1 Create a new Drawing or Impress document, then insert - table, e.g. 5*6
2 Select one of the cells in the inserted table, click button 'Split Cells'
  on the Table bar, split the cell into several cells, e.g. 5
3 Undo, please pay attention to the cells
4 Redo, please pay attention to the cells

Result
In step 3, the cell which has been splitted is selected, and the one following
this cell is selected too. Namely, two cells are selected in the same row.
In step 4, there is a new column is inserted

Expectation
In step 3, the cell which has been splited is selected, and the one following
this cell is not selected.
In step 4, the cell return to the status after step 2 

Li Meiying
Comment 1 Olaf Felka 2008-12-15 09:17:28 UTC
@ wg: Please have a look.
Comment 2 wolframgarten 2008-12-15 10:21:53 UTC
Reproducible. Reassigned.
Comment 3 Marcus 2017-05-20 10:55:15 UTC
Reset assigne to the default "issues@openoffice.apache.org".