Issue 97301 - arithmetic progression problem make OOo crashed after Merging Cells and Split Cells with the adjacent column
Summary: arithmetic progression problem make OOo crashed after Merging Cells and Split...
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: DEV300m37
Hardware: PC All
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: clippka
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-16 08:48 UTC by amy2008
Modified: 2009-10-12 17:32 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
three-cells-after-step3 (92.95 KB, image/png)
2008-12-16 09:30 UTC, amy2008
no flags Details
Step4:three-cells-select-cells-before-split-cells (93.38 KB, image/png)
2008-12-16 09:31 UTC, amy2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2008-12-16 08:48:58 UTC
Can reproduce it in Drawing and Impress with DEV300m37 on WinXP and Ubuntu

How to reproduce it 
1 Create a new Drawing (or Impress, it's up to you) document
2 Insert - table, 'Insert Table' dialog appears, set 'Number of column' and
  'Number of rows', e.g. 5columns * 12rows, OK
3 Select 3 row cells from the last row/line at one or more continual columns
  in the table, hit 'Merge Cells' on Table bar.
4 Select the merged cell formed at step3, meanwhile from the one or more
  continual columns which are next to the merged cell formed at step3, select
  3 cells from the last row/line, hit 'Split Cells' on Table bar, click 'OK'

Result
OOo crashes

Expectation
OOo works well

Attention
It's an arithmetic progression problem, I think.
supposed that there is a table with m rows and n columns, the number of cells
to make merge cells is x. Now, there are the rules for this issue
if x = 3, just select cells from n to n-2
if x = 4, just select cells from n to n-3 or n-1 to n-4
if x = 5, just select cells from n to n-4, n-1 to n-5 or n-2 to n-6
...


If my description is not clear, feel free to ask me anything anytime.

Regards
Li Meiying
Comment 1 wolframgarten 2008-12-16 09:09:11 UTC
Would it be possible to add screenshots to each step again? This helps very
much. Thanks in advance.
Comment 2 amy2008 2008-12-16 09:30:54 UTC
Created attachment 58845 [details]
three-cells-after-step3
Comment 3 amy2008 2008-12-16 09:31:28 UTC
Created attachment 58846 [details]
Step4:three-cells-select-cells-before-split-cells
Comment 4 wolframgarten 2008-12-16 10:50:14 UTC
Thanks, reproducible with your help.
Comment 5 wolframgarten 2008-12-16 11:19:29 UTC
The ID of the error report is rcjbwuc.
Comment 6 amy2008 2008-12-17 01:13:58 UTC
Meiying to Wolfram,
You're welcome,O(∩_∩)O~
Comment 7 clippka 2009-10-12 17:31:35 UTC
this issue is duplicate and has been fixed for some time now. I can't remember
the original issue number but I checked in dev300m60 and the issue is not
reproducable.
Comment 8 clippka 2009-10-12 17:32:07 UTC
closing