Issue 97309 - Writer app do not save "restart numbering" option at numbered paragraphs
Summary: Writer app do not save "restart numbering" option at numbered paragraphs
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.0
Hardware: PC Windows XP
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 104118 (view as issue list)
Depends on:
Blocks: 101565
  Show dependency tree
 
Reported: 2008-12-16 12:52 UTC by jkur
Modified: 2013-08-07 14:43 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
test-oo-97309.odt (28.89 KB, application/vnd.oasis.opendocument.text)
2009-01-02 09:52 UTC, bollin
no flags Details
Extended test document (33.12 KB, application/vnd.oasis.opendocument.text)
2009-01-22 08:56 UTC, lendo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jkur 2008-12-16 12:52:11 UTC
Writer app do not save "restart numbering" setting option at numbered paragraphs.
In ooo 2.4.1 it is o.k. After document re-opening  "restart numbering" is not set.
Comment 1 bollin 2009-01-02 09:52:35 UTC
Created attachment 59107 [details]
test-oo-97309.odt
Comment 2 bollin 2009-01-02 09:54:17 UTC
Is there any fix planned for this issue? I can reproduce the problem with the
Linux-Version of Openoffice.
Comment 3 lendo 2009-01-22 08:56:05 UTC
I can't reproduce this problem with own documents, but I can reproduce it with
your uploaded attachment. I will attach an extended document with some short
test cases.

I assume that this issue occurs because of your complicated huddle of paragraph
and list styles (OOoNum 123 Start, OOoNum 123 Cont, OOoNum 123 End, OOoNum abc
Start, OOoNum abc, ...). Do you have this problem only with some documents or
everytime even if you create a new document with OOo default formatting?
Comment 4 lendo 2009-01-22 08:56:53 UTC
Created attachment 59578 [details]
Extended test document
Comment 5 jkur 2009-01-22 11:11:51 UTC
I just found that the issue refers to documents created in 2.4.1 version (NO
complicated numbering or list styles) and edited and saved in 3.0.0. 
Newly created 3.0.0 seem to be are o.k.
Comment 6 lendo 2009-01-27 08:02:40 UTC
Ok, I can confirm this issue.

Create a document in OOo 2.4.1 with simple numbering and the "restart" option
and save it. Open this document in OOo 3.0.0 and insert a new numbering with the
"restart" option. Save it and open it again. -> OOo 2.4.1 shows the correct
restarted numbering, OOo 3.0.0 ignores the "restart" option for the numbering
inserted with OOo 3.0.0.
Comment 7 diocles 2009-02-10 14:53:06 UTC
Writing more text:start-value attributes into the XML generates files that can
be re-opened successfully by both OO.o 2.4 and 3.0:

--- test-oo-97309-broken/content.xml	2009-02-10 13:05:12.000000000 +0000
+++ test-oo-97309-fixed/content.xml	2009-02-10 14:47:58.000000000 +0000
@@ -68,14 +68,14 @@
     </text:list-item>
    </text:list>
    <text:list xml:id="list1810321782" text:continue-list="list1089051745"
text:style-name="OOoNum_20_123">
-    <text:list-item>
+    <text:list-item text:start-value="1">
      <text:p text:style-name="OOoNum_20_123_20_Start">Mail</text:p>
     </text:list-item>
    </text:list>
    <text:list xml:id="list1416129159" text:continue-list="list359127090"
text:style-name="OOoNum_20_abc">
     <text:list-item text:start-value="1">
      <text:list>
-      <text:list-item>
+      <text:list-item text:start-value="1">
        <text:p text:style-name="OOoNum_20_abc_20_Start">Icedove</text:p>
       </text:list-item>
       <text:list-item>

There has been a change to how start-value items get written between 2.4 and 3.0
in xmloff/source/text/txtparae.cxx. I have not yet read the ODF spec to see
whether these changes are correct.
Comment 8 diocles 2009-02-10 15:05:49 UTC
Looks like the other possible cause is the (new) use of text:continue-list
attributes. But fixing the text:start-value export would be sufficient.
Comment 9 chris 2009-02-13 17:46:28 UTC
The text:start-value element is actually being written in the XML, but it is 2
nodes up:

    <text:list xml:id="list1416129159" text:continue-list="list359127090"
text:style-name="OOoNum_20_abc">
     <text:list-item text:start-value="1">         <--- here
      <text:list>
       <text:list-item>
        <text:p text:style-name="OOoNum_20_abc_20_Start">Icedove</text:p>
       </text:list-item>
       <text:list-item>

So either this is being written at the wrong level, or there is an extra level
of XML in between. I need to have another look at what 2.4 does.
Comment 10 michael.ruess 2009-05-18 11:54:28 UTC
Reassigning this to OD as he is the appropriate developer for this stuff.
This seems to be highly related to issue 100262.
Comment 11 eberlein 2009-05-18 12:22:45 UTC
qualified as stopper for 3.1.1. please set new target and add to the blocker list.
Comment 12 Marcus 2009-05-18 12:38:33 UTC
set target to 3.1.1
Comment 13 Marcus 2009-05-26 10:07:48 UTC
cc'ing
Comment 14 Oliver-Rainer Wittmann 2009-05-28 12:25:31 UTC
Ok.
The defect description is not very well, but when I am right the defect is, that
a "restart numbering" set at paragraph "Icedove" is not correctly stored into
ODF. Correct?
To reproduce this defect I performed the following steps:
- open the given document in OOo 3.0 or later
- restart numbering via context menu at paragraph "Icedove"
- save
- close
- reload
--> restart numbering lost at paragraph "Icedove"

The restart numbering at paragraph "Mail" works in OOo 3.1

As haggai already said, the defect cause seems to be that the start value is
stored at the wrong element.

Some notes about the given document:
- It contains two lists which are intersecting:
-- paragraphs "Browser" and "Mail" are in the first list.
-- paragraphs "Iceweasel", "Opera", "Internet Explorer", "Icedove" and "Outlook"
are in the second list.
-- the list items of the second list are all on the list level 2

Some notes about the document given by lendo:
- paragraph "Itch" starts with "b)", because it belongs to the second list and
is on list level 1
- the last example "works", because the list items of the second list are on
list level 1
Comment 15 Oliver-Rainer Wittmann 2009-06-24 17:22:41 UTC
fixed in cws mav53 - changed file:
/xmloff/source/text/txtparae.cxx, rev. 273361

The text:start-value attribute is now attached to the correct <text:list-item>
element.
Comment 16 Oliver-Rainer Wittmann 2009-06-29 09:46:12 UTC
OD->MRU: Checked in internal installation set of cws mav53 - please verify.
Comment 17 michael.ruess 2009-07-07 15:50:35 UTC
Verified fix in CWS mav53.
Comment 18 michael.ruess 2009-07-30 09:11:00 UTC
Checked integration in DEV300m53 and OOO310m16.
Comment 19 michael.ruess 2009-08-10 08:15:00 UTC
*** Issue 104118 has been marked as a duplicate of this issue. ***
Comment 20 michael.ruess 2009-09-02 18:23:44 UTC
*** Issue 104721 has been marked as a duplicate of this issue. ***