Issue 97383 - deadlock when insert itself as an object
Summary: deadlock when insert itself as an object
Status: CLOSED DUPLICATE of issue 92300
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: groucho266
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2008-12-18 07:46 UTC by doze_worm
Modified: 2013-08-07 15:20 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description doze_worm 2008-12-18 07:46:14 UTC
[Steps]
1. Create a Impress doc, and save it. (e.g. save the doc as name "test.odp")
2. "Insert -> Object -> OLE Object", pop up "Insert OLE Object" Dialogbox.
Select "Create from file", choose the file we just saved, which name is
"test.odp", select "Link to file", and left-click OK button.
3. left-click "Save" button in standard toolbars. Then close the doc.
4. Open the "test.odp" doc.

[Result]
Program deadlock, and lost response.

[Expectedness]
While a cycle insert has been detected, give some warning, and prevent.
Comment 1 amy2008 2008-12-31 02:03:37 UTC
Reproducible with DEV300m37 on WinXP and Fedora
Li Meiying
Comment 2 wolframgarten 2009-01-06 10:15:05 UTC
Reproducible. Reassigned.
Comment 3 amy2008 2009-04-20 07:14:23 UTC
Duplicate to issue 92300

*** This issue has been marked as a duplicate of 92300 ***
Comment 4 amy2008 2009-04-22 04:18:33 UTC
Closing